Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKII Supra

Reply
 
Thread Tools Display Modes
Old 02-29-2008, 04:48 AM   #1
thrsdy1203
Stock
 
Join Date: Feb 2008
Location: Gig Harbor
Posts: 2
thrsdy1203 is on a distinguished road
Default Diagnosing an Issue

Let me begin with a short story (sorry)

So i have been dying to get my paws on a Supra specifically an MK2 because i really like the body style alot.. just my kind of taste that is all so i was at my friends house and her sons friend has one a 1982 Supra Originally owned by his father bought brand new off the lot in 1982 with now 160,000 miles i talked to guy and all he wants is it to be off his friends moms property and so i offered him my excellent running 1987 Chevy Nova he took it and said get my car supra running and on the road and we will do the title transferring from there as i do not want to do the trade unless my car (his supra) is running right.. AWSOME! im stoked out like a mofo

Problem is that the car starts up but you have to keep the foot on the gas to keep the car running soon as you let off the gas it dies i took it down the street and back and it barley crawls yes the car is running out of gas so yes that could be one problem but it should have more power to it then what it is yielding spark plug wires are newish and they said it needs a fuel pump however going off my car with it having a bad fuel pump it died and it never started or ran until i fixed the pump...so i dont if that is the problem...

Also it smells a little rich when i get out of car or some kind of smell im assuming a rich gassy smell...i do know my cars a little i have a beginners knowledge of cars

Also car sat since 2004 because it would not pass emmisions but being a 1982 it should not need emission now..does it? if so how do you go about fixing that?

Please help me out as i really really want this Supra...
thrsdy1203 is offline   Reply With Quote
Old 03-01-2008, 02:12 AM   #2
Supra Goddess
Intake
 
Supra Goddess's Avatar
 
Join Date: Feb 2005
Location: Lakewood, WA
Posts: 38
Supra Goddess is on a distinguished road
Default

Could possibly be a clogged catalytic converter. It could be a lot of things actually. From the fuel pump to the AFM crapping out, kind of hard to diagnose online. I'd suggest reading through the Chilton's or Haynes manual on the car. The online TSRM can only do so much, it is for a 1986 Supra which is a lot different than the '82. The '82 cars were kind of oddballs with one off AFMs, vacuum advance distributor, etc.

Try driving it at night for a bit and then check under the hood and under the car to see if the manifold or exhaust pipes are glowing red.
Supra Goddess is offline   Reply With Quote
Old 03-08-2008, 01:44 AM   #3
thrsdy1203
Stock
 
Join Date: Feb 2008
Location: Gig Harbor
Posts: 2
thrsdy1203 is on a distinguished road
Default

so if it had a bad fuel pump it would still run...just like pure shit tho...?
thrsdy1203 is offline   Reply With Quote
Old 03-08-2008, 09:06 PM   #4
Supra Goddess
Intake
 
Supra Goddess's Avatar
 
Join Date: Feb 2005
Location: Lakewood, WA
Posts: 38
Supra Goddess is on a distinguished road
Default

fuel pumps go bad in different ways. most pumps just stop working and then you don't have any gas going to your engine, therefor it just won't run anymore. some other times, the fuel pump overheats after a few minutes and THEN shuts down causing the car to run like ass and then stop running.

If your car is an '82, it doesn't have to pass emissions. I would take the catalytic converter off, replace it with the appropriate piping and see if the car runs better w/o it.

Also, you might want to try putting some gas in it. It is not a good thing to be running it low on gas, especially after it has sat for a long time. There's probably a ton of gunk on the bottom of the gas tank that the fuel pump is trying to suck up... and that's no good!
Supra Goddess is offline   Reply With Quote
Old 03-09-2008, 10:00 PM   #5
Mark's MKII
3" Exhaust
 
Join Date: Apr 2006
Location: Joelton TN.
Posts: 70
Mark's MKII is on a distinguished road
Default

A timing belt that has jumped a tooth or 2 will make it run that way. So I would look under the timing cover to see if all is in order.
__________________
7MGTE
Mark's MKII is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Tachometer Issue teflon44 MKIV Supra 10 09-06-2009 04:02 PM
Blow off valve / idle issue AlpWhitE46 MKIII Supra 9 10-11-2008 12:49 AM
Diagnosing a problem cgreiner MKIII Supra 11 08-29-2008 12:54 PM
for people who were following my pcv issue Kuban MKIII Supra 11 04-12-2007 09:58 AM
issue..fixd both tie rods buh still clank 88Tsupra MKIII Supra 5 03-05-2007 06:19 PM


All times are GMT. The time now is 06:25 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86