Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 08-06-2013, 05:23 PM   #1
ccorbin81
Stock
 
Join Date: Apr 2011
Location: CO
Posts: 9
ccorbin81 is on a distinguished road
Default Ignition Problems

Hi,

I have an 88 Supra Turbo and recently it has had ignition problems. It turns all day but will not fuel because the pump isn't recieving power. The B+ terminal is dead, if I jump 12 volts to it the car starts and runs beautifully.

I replaced all fuses in the kick panel and fuse box under the hood including the alternator fuseable link. I have power to the IGN fuse in the driver kick, power to the EFI fuse and EFI Main Relay, I have removed the glove box to gain access to the ECU but I am not very good with wiring schematics and I don't know what circuits or wires to test on the ECU. I did check as many grounds as I could find and they all are clean and secure. I replaced the ignition switch but from what I read it was gaining power on the correct wires off of the switch anyway.

It has been very wet here lately and I fear there may be a short. Is there a dummy's guide to troubleshooting this circuit?

Can someone assist me with what I should do next?

Thanks in advance

Last edited by ccorbin81; 08-06-2013 at 05:26 PM.
ccorbin81 is offline   Reply With Quote
Old 08-09-2013, 04:37 AM   #2
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

How far back in the circuit do you have power? Is there power at +B1 and BATT? Are you testing +B in the diagnostic box or at the ECU? You have power everywhere else in the car?

Kinda wet? Here, in Colorado.... well, I guess for Colorado one could make the argument but it hasn't been wet enough to cause major electrical failures unless your car is missing a lot of body panels and the windshield.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 08-09-2013, 03:27 PM   #3
ccorbin81
Stock
 
Join Date: Apr 2011
Location: CO
Posts: 9
ccorbin81 is on a distinguished road
Default

Hey Cre, thanks for responding. Sorry for the confusion, I am currently living in Western NC, record rainfall this year so far.

I was testing the B+ wire at the diagnostic port. Im not with the vehicle now but I suppose I need to know where the power to the diagnostic port is supplied. Or should I be directing my search towards ECU power first?

Everything else in the vehicle gets power to my knowledge, it ran/idled fine and I have no warning lights. I haven't been back into the vehicle since this post (more rain).
ccorbin81 is offline   Reply With Quote
Old 08-11-2013, 07:59 PM   #4
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Warning lights don't come on for all issues. You still need to check for diagnostic codes. See the MKIII FAQ section for a thread on how to do so.

Here's a link for an online version of the TEWD (Toyota Electrical and Wiring Diagrams) manual.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
My mk3 wont start please help - Intermittent ignition problems 1_BAD_MK3 MKIII Supra 19 01-14-2010 09:09 AM
problems problems problems.... 86SupraMan MKIII Supra 5 02-04-2008 04:28 PM
Starting problems and accleration problems! alekjame22 MKIII Supra 6 03-17-2007 11:19 PM
problems, problems, and problems tone loc MKIII Supra 6 09-06-2006 05:35 AM
Ignition write up.. midwestmk2 MKII Supra 0 06-11-2006 03:56 AM


All times are GMT. The time now is 07:21 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86