Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 03-22-2011, 02:53 AM   #1
the_snuggler
Stock
 
Join Date: Mar 2011
Location: Paducah, KY
Posts: 8
the_snuggler is on a distinguished road
Default 92 7mgte problems

(sorry for the wall of text)


So here's the story. I joined the military and sold my car right before leaving for basic and AIT. While in AIT looking for a new car on craigslist I come across a 92 supra turbo. Send my mom the link for it, had her check it out test drive it and all that good stuff. Everything ran fine and she said it was a great drive and that she loved the car.

I get home about a month and a half later. Ride into town a couple of times, everything is great, all fluids are good yatta yatta. Then it just started messing up. Oil leaking but no spots on the ground or no smell of burning.

I was told that a seal could possibly be messed up on the turbo. So I took it to the dealership to have them look at it. They said I needed a new turbo and that it would run me 6 grand. So I took it down to a shop to get it rebuilt. He told me it was recently rebuilt and that the turbo was fine.

This is where it gets funked up.

We get the turbo back on and now all of sudden it dies when it's in neutral after driving it. It dies if the clutch is held in for more than 2 seconds, it chugs occasionally as if it's not getting gas when you accelerate and now it smells like oil is burning and some smoke will come out the exhaust on occasion. It idles really low (probably 400 rpm) all of a sudden and smells weird.

I took it back to toyota today and told them they were full of shit and that I just wanted the codes back because the check engine light had been on. This is what they got:
21 Oxygen sensor malfunction. 24 intake air temp sensor, 31 mass air meter malfunction, 34 turbo pressure abnormal. Removed intake air tubes and found oil inside tubes due to engine blow by. Has had oil build on spark plugs. Removed cyl #1 and 2 spark plugs to check compression. Compression 100 psi on #1 and 110 on #2. Recommend replace or rebuild engine along with spark plugs, plug wires, any and all coolant hoses, timing belt and drive belts.

They wanted to charge me 6 grand for a new engine alone. I don't know anything about cars but I know this is obvious horse shit. This is my first turbo car and I have no clue what to do or where to start. Can I please get help.

(again sorry for the wall of text)
the_snuggler is offline   Reply With Quote
Old 03-22-2011, 10:40 PM   #2
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Quote:
Originally Posted by the_snuggler View Post
I don't know anything about cars
This is the killer.... I'm no longer giving long distance courses on auto mechanics; It's a thankless position and seldom goes well.

There is the possibility of a blown head gasket causing those low compression readings you would need to do a dry compression test and a wet test back to back to see if the compression changes at all.

The turbo error code may be a bad airflow meter or an opening or tear in the intake piping.

Codes 24 and 31 will happen if you unplug the airflow meter while the ignition is on, I would disregard that unless it is recurring.

The oxygen sensor is only a trim sensor, for not just check the wiring for shorts and leave it alone.

You can get the turbo rebuilt (if it's a good core) for $600, no need to spend $6,000 on a new one.

A *full* rebuild will usually cost you under $4,000; It depends on the market in your area and the availability of used parts if needed.

I hate to be the kind of person who just says read the f'in manual... but, RTFM:
http://www.cygnusx1.net/Supra/TechTi...ror_codes.aspx
http://www.cygnusx1.net/Supra/Library/TSRM/MK3/

Take it step by step... start with dry and wet compression tests.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 03-22-2011, 11:58 PM   #3
the_snuggler
Stock
 
Join Date: Mar 2011
Location: Paducah, KY
Posts: 8
the_snuggler is on a distinguished road
Default

I do thank you for the help you've provided, but I'm not really looking for courses on doing it myself. More or less looking for opinions on what I should do, how much I'm looking at to get it fully fixed and possibly merchants people on the forums use to get their parts from.

Thank you for the link to the manual going to start reading it now.
the_snuggler is offline   Reply With Quote
Old 04-28-2011, 06:45 PM   #4
the_snuggler
Stock
 
Join Date: Mar 2011
Location: Paducah, KY
Posts: 8
the_snuggler is on a distinguished road
Default

I'd like to thank you for that manual it helped alot. After taking off the air filter and all that jazz, I came to find out that my mechanic forgot to put a hose back on on the bottom of the big tube that's connected to the turbo.
the_snuggler is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
7MGTE to 7MGE karu MKIII Supra 4 10-22-2010 08:22 AM
Starting problems and accleration problems! alekjame22 MKIII Supra 6 03-17-2007 11:19 PM
problems, problems, and problems tone loc MKIII Supra 6 09-06-2006 05:35 AM
Just got a '90 7mgte - few problems Pearl Mica MKIII Supra 2 12-04-2005 10:22 AM


All times are GMT. The time now is 12:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86