Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 02-26-2010, 10:24 PM   #1
StonecoreTx
Intake
 
Join Date: Dec 2009
Location: Austin,Tx
Posts: 41
StonecoreTx is on a distinguished road
Default Inspection/emission problem

Earlier this week I decided to take my Mk3 to get her a new (Texas) inspection sticker. I was pretty sure it would pass, however, it didn't.

I just replaced my passenger quarter fender and fixed my taillights and turn signals, so I figured time its time for inspection!

My mk3 is a 86.5 7mgte with a r154 and it failed emissions.

second opinion from fellow mk3 owners would help
I'm thinking i need to check/replace DP,EGR,VTV,VSV, maybe a cat converter?

I'm running high in HC's and CO's but passed dilution. any advice?

High speed
pollutant - Standard - My reading.
HC - 220 - 247
CO - 1.20 - 3.92

low speed
pollutant - standard - My reading
HC - 220 - 428!
CO -1.20 - 1.52
__________________
86.5 mk3 supra 7mgte r154
StonecoreTx is offline   Reply With Quote
Old 02-27-2010, 12:03 AM   #2
mirage83
12psi boost
 
Join Date: Feb 2007
Location: Georgia
Posts: 359
mirage83 is on a distinguished road
Default

For the high HC check plugs, EGR, vacuum lines, stuff like that. Even your timing being off some can raise HC.

For CO, check your O2 sensors/wires, air filter. The TPS, coolant temp sensor and/or the AFM could also be responsible.
mirage83 is offline   Reply With Quote
Old 02-27-2010, 12:49 AM   #3
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

EGR will cause high NOx, I don't think it's suspect here.

HC and CO are both due to running excessively rich. I would start with checking for diagnostic error codes, then check plugs, air filter and timing... then we'll move on to bigger things.

Check codes: http://www.cygnusx1.net/Supra/TechTi...ror_codes.aspx

Look in the MKIII FAQ for info on setting timing; You probably don't need to worry about the mechanical timing, just the spark advance.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 02-27-2010, 01:21 AM   #4
mirage83
12psi boost
 
Join Date: Feb 2007
Location: Georgia
Posts: 359
mirage83 is on a distinguished road
Default

I knew a bad EGR can create high NOx, but for some reason I was thinking that a leaking or bad EGR might be causing a rise in HC under some conditions.
mirage83 is offline   Reply With Quote
Old 02-27-2010, 03:22 AM   #5
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Nah, a leaking EGR shouldn't cause any changes in your engine's emissions as the gasses are inert. A clogged or otherwise nonfunctional EGR will contribute to greater amounts of ping or knock which would result in the ECU pulling timing and adding fuel but it would also result in a big increase in NOx.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 02-27-2010, 08:33 PM   #6
Cameroonski
3" Exhaust
 
Join Date: Dec 2009
Location: Austin, Tx
Posts: 68
Cameroonski is on a distinguished road
Default

Glad to see a fellow supra owner near by, I'm from Pflugerville just north of you and have been workin on a supra i bought for a few months and still havent had the chance to get it inspected. I'm pretty sure i have to fix at least an exhaust leak, but I also cleared out the cat. So I might run into the same type of problems that your having. All I can say is good luck!
Cameroonski is offline   Reply With Quote
Old 03-05-2010, 05:44 AM   #7
StonecoreTx
Intake
 
Join Date: Dec 2009
Location: Austin,Tx
Posts: 41
StonecoreTx is on a distinguished road
Default

I looked at my EGR system today. I ran into an interesting problem. No EGR valve. a modulator connected to nothing. no block off plates.
The guy I bought the supra from said it has a jdm head so maybe this supports it all and why i'm not passing emissions. jdm or not?
Should I install a EGR valve or get block off plates?
does a JDM 7m have EGR cooler?
The car seems to have been running without block off plates for some time and should this be a concern?

modulator with no ERG valve... conneced to nothing.

no block off plates. looks like this. are block off plates necessary if EGR is missing/removed? does JDM have EGR port like above? located just under the modulator a bit. (obviously that is not a ERG flange but it looks similar.)
__________________
86.5 mk3 supra 7mgte r154
StonecoreTx is offline   Reply With Quote
Old 03-05-2010, 06:41 AM   #8
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

The heads are the same, the cooler is capped though, IIRC. The EGR modulator port should be covered too though.

So, what were the NOx results? Have you by chance looked to see if the ECU is USDM or JDM? I'm curious and would like to know more.

I'm not sure if it's the same situation with JDM GTE intakes, but the GE's intake doesn't have any of the porting for the EGR. To add EGR to a JDM 7M-GE you have to swap over the upper USDM intake plenum/surge tank and the USDM "Y" pipe. I suspect that you would need a USDM upper intake plenum/tank along with the cooler plate and the modulator. The wiring may vary a little too, but I am unsure.

Have you checked for error codes? Checked anything Mirage suggested?
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS Problem? rasclaat_98 MKIII Supra 6 12-13-2010 09:53 PM
speed sensor problem nadircicek Non-Generation Specific Questions 8 10-09-2009 06:58 PM
electrical problem! I think!!!!!help!! Boostcrazy61 MKII Supra 0 08-21-2009 01:08 AM
another heater problem nicnet MKIII Supra 16 12-05-2007 10:18 PM
Nissan Sentra Tranny problem. redmaro Off Topic Forum 2 11-28-2006 01:58 PM


All times are GMT. The time now is 09:52 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86