Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKII Supra

View Poll Results: how much horsepower can the stock rear handle?
450 1 100.00%
550 0 0%
650 0 0%
under 450 over 350 0 0%
Voters: 1. You may not vote on this poll

Reply
 
Thread Tools Display Modes
Old 08-21-2009, 01:08 AM   #1
Boostcrazy61
Stock
 
Join Date: Aug 2009
Location: new york
Posts: 1
Boostcrazy61 is on a distinguished road
Angry electrical problem! I think!!!!!help!!

hey whats up fellas!!! i have a serious headache and i dont no what to do. this is my first toyota project so i am really not that familiar with the motor so i am using basic motor knowledge and learning as i go. i built a 700horsepower motor which includes

fordge crank and rods
je pistons
fully ported head and valve springs and retainers
31/2inch custum built down pipe
3inch custom built exhaust no cat
550cc injectors venum (i have the 750ccs aswell but not ready to turn it up yet)
stock harness and stock ecu ( using aem standalone for fuel management)
dual ballbearing t61 turbo with a gts compressor housing
hks sequential blow off valve
3 inch piping and a epic intercooler
turbonectics manual boost controller
5 stage racing clutch and a short shifter

the problem am having is that there something draing the power and i cant figure out what. sometimes the car will start and run on the stock ecu and then i turn it off and come back to it the next day and the car is dead! i changed all the sensors, i paid to have my harness rewired, everything. the car now turns over but wont start, now when i purchased the gar it was sitting for 2years before it last ran. there is a small leak in the targa top that run to the ground if it rains hard. is there some sort of problem that i am not checking? i have'nt even broken the motor in cause i cant get the car to run! its a new motor but an old car. i have had this problem for the last 2years!! i had to hold up the entire project to figure out this problem!! dying to take the car to the track!!! i am thinking its electrical and i should by a new harness. please can somebody save me from this torture!!!!
Boostcrazy61 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
AFPR vacuum hoses and an electrical problem Gunnar Non-Generation Specific Questions 0 06-11-2009 08:46 PM
Frustrating electrical problem thebobfoster Non-Generation Specific Questions 1 05-30-2009 10:16 PM
Electrical problem suprabahamut MKIII Supra 4 04-06-2008 08:34 PM
7mge swap, electrical problem 89n/aA/T-2turbo5spd MKIII Supra 5 08-15-2007 07:51 AM
electrical problem mizuboi MKIII Supra 4 03-05-2007 05:56 PM


All times are GMT. The time now is 07:48 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86