Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIV Supra

Reply
 
Thread Tools Display Modes
Old 11-16-2005, 10:11 PM   #1
tex1116
Stock
 
Join Date: Oct 2005
Posts: 6
tex1116 is on a distinguished road
Default Engine noise car wont stay running

I have 88 supra turbo. I recently made a post about car not starting with possible starter issues. The starter still may be a problem but today I was able to get it to crank. It seemed like a rather fast cranking and it wasnt starting so i took off the front engine cover and peeked in to see if the timing belt was broken but it looked fine. Then i inspected the spark plugs which looked pretty oily around the center electrode and appeared to have a significant amount of oil in the spark plug holes(is that normal, it was enough to see my reflection). so i wiped a couple off and reassembled and when to start the car again. There was signs of life but still no starting. I kept at it for awhile and tried starting with the accelerator pressed in which within a couple seconds brought the car to a pretty shaky start. I kept the accelerator pressed in at around 1000-2000 rpms and i could here some pretty disturbing noises from the engine like rapid dull thuds and tapping and as soon as I released the gas petal it died. I tried it a few times to the same effect. Any ideas?

I also just realized this is the wrong forum, but still any help would be appreciated
tex1116 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
85 engine noise long-cat MKII Supra 0 12-03-2008 08:02 PM
HELP! My engine just started a weird noise... idoke MKIII Supra 12 10-05-2006 05:06 PM
Engine not running to well... Nickss454 Non-Generation Specific Questions 0 09-05-2006 11:55 AM
clicking noise from engine Chomper Non-Generation Specific Questions 6 11-22-2005 04:09 AM
engine noise car dies after starting tex1116 MKIII Supra 7 11-18-2005 06:47 PM


All times are GMT. The time now is 09:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87