Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > General Discussions > Non-Generation Specific Questions

Reply
 
Thread Tools Display Modes
Old 11-18-2005, 05:06 PM   #1
Chomper
Stock
 
Join Date: Sep 2005
Posts: 27
Chomper is on a distinguished road
Default clicking noise from engine

There is the clickng noise when engine is on, but it goes away when I step on the clutch. Can someone tell me what this sound is?
Chomper is offline   Reply With Quote
Old 11-19-2005, 12:30 AM   #2
mrnickleye
1000whp postwhore
 
mrnickleye's Avatar
 
Join Date: Jun 2005
Location: Mojave Desert, Calif.
Posts: 1,705
mrnickleye is on a distinguished road
Unhappy

When you press the clutch pedal all the way down, you have basically dis-connected the transmission from the engine.

The input shaft bearing in the trans might be going bad.

Very rare, but the throw out bearing may be barely touching the pressure plate when the pedal is not being pressed.. Try and press the clutch pedal a tiny bit, just a little tension on it, and see if the clicking stops.
mrnickleye is offline   Reply With Quote
Old 11-21-2005, 02:36 AM   #3
Chomper
Stock
 
Join Date: Sep 2005
Posts: 27
Chomper is on a distinguished road
Default

No, the clicking only stops when clutch is all the way down.
Chomper is offline   Reply With Quote
Old 11-21-2005, 06:02 AM   #4
WiseAssJester
3" Exhaust
 
Join Date: Sep 2005
Location: Reno
Posts: 77
WiseAssJester is on a distinguished road
Default

When you've got the clutch to the floor, rev the motor a couple of times. Does the noise come back?
WiseAssJester is offline   Reply With Quote
Old 11-22-2005, 12:23 AM   #5
Chomper
Stock
 
Join Date: Sep 2005
Posts: 27
Chomper is on a distinguished road
Default

Sorry, its not really a clicking noise. Its more like a squeeking sound, but has that on and off thingy to it, like something rotating. It might just be the stuff spinning inside the transmission. Is it possibe that it might be on low fluid.
Chomper is offline   Reply With Quote
Old 11-22-2005, 03:29 AM   #6
mrnickleye
1000whp postwhore
 
mrnickleye's Avatar
 
Join Date: Jun 2005
Location: Mojave Desert, Calif.
Posts: 1,705
mrnickleye is on a distinguished road
Default

The input shaft bearing in the trans might be going bad. Check/change the oil, first. Get a bottle of 'LUCAS' trans oil treatment, follow directions on bottle.
mrnickleye is offline   Reply With Quote
Old 11-22-2005, 04:09 AM   #7
Chomper
Stock
 
Join Date: Sep 2005
Posts: 27
Chomper is on a distinguished road
Default

i'll do that. thanks for the help you guys.
Chomper is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
85 engine noise long-cat MKII Supra 0 12-03-2008 08:02 PM
HELP! My engine just started a weird noise... idoke MKIII Supra 12 10-05-2006 05:06 PM
clicking noise mizuboi MKIII Supra 1 09-29-2006 01:51 AM
engine noise car dies after starting tex1116 MKIII Supra 7 11-18-2005 06:47 PM
Engine noise car wont stay running tex1116 MKIV Supra 0 11-16-2005 10:11 PM


All times are GMT. The time now is 11:52 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87