Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 09-10-2013, 02:28 AM   #1
Raiden93
Stock
 
Join Date: Sep 2013
Location: Athens, GA
Posts: 1
Raiden93 is on a distinguished road
Default 7mge turns but won't start

Hey I'm new to the site. Novice car guy. Owner of a 91 Mk3 Auto.

My car won't start and I can't seem to figure it out.
For a while now from time to time when I put the key in and turn it nothing will happen other than all of the lights will turn on, radio will turn on, and I will here a single clicking sound. I will play with this for a while and then the car will start up and be fine for a week or two then the problem will occur again. Well the other night I was leaving work and this happened. I got it to start, got down the road a ways and all of a sudden I started to lose power, it puttered, I came to a complete stop at a light and it quit on me. Now the car will either do nothing other than the lights and click or it will turn but not start and then white smoke comes from the TB and exhaust accompanied by the weakest putter and a fuel odor.

I had to have the thing towed home. The tow truck driver said he thought it was the fuel pump. I don't know about this. I am stuck, it is my only car and I need to fix it ASAP. Please help!
Raiden93 is offline   Reply With Quote
Old 09-10-2013, 06:19 AM   #2
S-mk3-B
3" Exhaust
 
S-mk3-B's Avatar
 
Join Date: Mar 2012
Location: San Francisco
Posts: 72
S-mk3-B is on a distinguished road
Default

Well it could be that you have an old starter and that could be the reason for your starting problems. As for the random stall while you were driving im not too sure of, maybe bad grounds, clogged injectors, etc... I'm sure someone else will be able to further help you on this problem
__________________
1989 Toyota Supra Turbo w/ Targa Top
White Exterior-Blue Interior
3" Blitz Catback Exhaust System
BIC Divorced Downpipe, Straight Pipe
Megan Track Coilovers
Apexi BOV, Turbo Timer, and Intake
Lexus Projector Fogs
Bride Low Max Replica
S-mk3-B is offline   Reply With Quote
Old 09-10-2013, 08:17 AM   #3
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Ignition coil, VAFM and distributor are where I'd start. The VAFM is a possibility as well but when that goes south to the point of complete failure it usually happen when the engine bay gets hot and then works again once it cools (not applicable to the 7M-GTE's KVAFM). What does the smoke smell like? Refer to the thread in the MKIII FAQ section about error/diagnostic codes, check for codes and post back if any are present.

You can test the fuel pump by inserting a wire jumper across the FP and B+ terminals in the diagnostic box and turning the ignition to "ON"... just see if you can hear the sound of the pump or the sound of fuel moving through the fuel rail. Usually when a fuel pump goes it's totally shot, worth taking a look but there are other components I'd look at first if it were me.

(see the on-vehicle inspection portion for the 7M-GE in particular)
http://www.cygnusx1.net/supra/Librar....aspx?S=IG&P=1
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
7mge trouble toyotaspirit MKII Supra 2 07-12-2012 08:21 AM
86.5 7MGE wont start , no spark Spitfire_Fox MKIII Supra 6 06-24-2011 04:25 PM
7mge hp increase info 907mge MKIII Supra 14 02-05-2011 03:03 AM
Engine still wont start 87 supra 7mge lilsmitty MKIII Supra 12 01-12-2006 10:53 PM


All times are GMT. The time now is 05:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86