Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 05-27-2011, 02:41 AM   #1
the_snuggler
Stock
 
Join Date: Mar 2011
Location: Paducah, KY
Posts: 8
the_snuggler is on a distinguished road
Default New problems

So I made a post a couple of months ago or something like that. Pretty much I had abnormal turbo pressure, low compression and a couple of other things.

After take off the intake and noticing that my mechanic forgot to put one tiny hose back on on the bottom of it, I fixed the problem with the turbo and my messed up acceleration.

Now, I've been having pretty decent oil consumption, but there's never any on the ground or anything. there's usually a little bit of white smoke when I first start it up at the beginning of the day, and you can smell that's it been burning after driving it. I've been told one of the problems is that my turbo is sucking it out. so I took it to a "turbo specialist" and he said it was recently rebuilt and that there was only a couple of things he could see that would need replacing.

So I put the turbo back on, and it's still consuming oil, as i've taken the intake off and there is oil in the turbo after getting rebuilt. I've also read these cars have bad head gaskets?

Also it doesn't feel like it's getting all the power it should be. and I noticed that when I try to accelerate harder from lower rpms it makes this strange sound as if maybe theres a little piece of something rattling around when the turbo kicks in.

I'm sorry for all the text but i'm supra noob and I really just want to make this car into something great because it's the only mkIII in town. So any information, tips or any wisdom of any kind that can help me would be greatly appreciated.
the_snuggler is offline   Reply With Quote
Old 05-27-2011, 05:09 AM   #2
916MKIIIx2
3" Exhaust
 
Join Date: Nov 2008
Location: California
Posts: 152
916MKIIIx2 is on a distinguished road
Default

Now, to clarify does it sounds like pinging, metal on metal tapping hard, or does it sound like a qrtr is being spun in a jar?
916MKIIIx2 is offline   Reply With Quote
Old 05-27-2011, 05:14 AM   #3
the_snuggler
Stock
 
Join Date: Mar 2011
Location: Paducah, KY
Posts: 8
the_snuggler is on a distinguished road
Default

more like a quarter in a jar
the_snuggler is offline   Reply With Quote
Old 05-27-2011, 05:34 AM   #4
916MKIIIx2
3" Exhaust
 
Join Date: Nov 2008
Location: California
Posts: 152
916MKIIIx2 is on a distinguished road
Default

That doesn't seem good, pull the intake off and check the turbo blades for damage assuming the sound is coming from the turbo.
916MKIIIx2 is offline   Reply With Quote
Old 05-27-2011, 05:39 AM   #5
the_snuggler
Stock
 
Join Date: Mar 2011
Location: Paducah, KY
Posts: 8
the_snuggler is on a distinguished road
Default

alright, I'll do that tomorrow after work, but is it hard to pull the turbo itself off?
the_snuggler is offline   Reply With Quote
Old 05-27-2011, 05:48 AM   #6
916MKIIIx2
3" Exhaust
 
Join Date: Nov 2008
Location: California
Posts: 152
916MKIIIx2 is on a distinguished road
Default

Nah shouldn't be too hard, look up a guide first if you're not sure what to do, there are many of them on just start googling or searching the forums here for, 7mgte turbo removal guide
916MKIIIx2 is offline   Reply With Quote
Old 05-27-2011, 06:01 AM   #7
the_snuggler
Stock
 
Join Date: Mar 2011
Location: Paducah, KY
Posts: 8
the_snuggler is on a distinguished road
Default

alright cool, i'll get to it after work tomorrow and post back results and some pictures. thank you
the_snuggler is offline   Reply With Quote
Old 05-28-2011, 01:54 AM   #8
the_snuggler
Stock
 
Join Date: Mar 2011
Location: Paducah, KY
Posts: 8
the_snuggler is on a distinguished road
Default

work ran late today so didn't get to it. if anyone has any other suggestions to my problems please let me know what I can do!
the_snuggler is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to buy a Supra, though having some problems finding one. Cypherbku MKIV Supra 3 03-03-2009 01:45 AM
problems problems problems.... 86SupraMan MKIII Supra 5 02-04-2008 04:28 PM
Starting problems and accleration problems! alekjame22 MKIII Supra 6 03-17-2007 11:19 PM
Oil leak problems adellicson MKIII Supra 1 03-04-2007 10:11 PM
problems, problems, and problems tone loc MKIII Supra 6 09-06-2006 05:35 AM


All times are GMT. The time now is 11:45 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86