Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 04-19-2011, 09:03 PM   #1
cfurlan
Intake
 
Join Date: Oct 2010
Location: Indiana
Posts: 38
cfurlan is on a distinguished road
Default About to give up

I bought a 87 supra turbo that was freshly rebuilt. Well the kid did not put a thermostat in it so I installed one. I took it for a test drive afterwards and it overheated right away. Later I noticed that the rubber plug on the back of the engine blew out. Car was running very badly and would not stay running without giving it gas. I then pulled the whole motor and did a complete rebuild with bearings and seals. I had the head checked at the machine shop and it was all in spec, and it was resurfaced on the previous rebuild. I put it all together and the car barely ran and was missing very badly. After two months of not working on it a came across a parts car. So I redid the head gasket and changed the head, coil packs, plugs, wires. It is still missing badly. I have great compression with new je pistons and rings. Fuel pump is working great with great fuel pressure. I am getting great spark on all cylinders. I checked, double checked, and triple checked the timing. I know it is perfect. As of now the car will not stay running on its own, I have to give it a little gas. I've also check all the vacuum lines and they are all good. Please if anyone can help I will be greatly appreciated. Next I'm going to swap out ecu's to see if that will help. It is not throwing any codes at all. My name is Chris. If it's easier you can call or text 574-387-1777. Thanks
cfurlan is offline   Reply With Quote
Old 04-19-2011, 10:33 PM   #2
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Tried running it with the airflow meter unplugged?
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 04-19-2011, 10:35 PM   #3
cfurlan
Intake
 
Join Date: Oct 2010
Location: Indiana
Posts: 38
cfurlan is on a distinguished road
Default

Not yet, I will try that real quick.
cfurlan is offline   Reply With Quote
Old 04-19-2011, 11:02 PM   #4
cfurlan
Intake
 
Join Date: Oct 2010
Location: Indiana
Posts: 38
cfurlan is on a distinguished road
Default

By unplugging it, it made it worst to where it did not want to start at all. It would go put put put and then die every time. Even when trying to give it a little gas.
cfurlan is offline   Reply With Quote
Old 04-20-2011, 04:15 AM   #5
Conga1991
3" Exhaust
 
Join Date: Jun 2009
Location: Avondale, AZ
Posts: 169
Conga1991 is on a distinguished road
Default

Well it's not the sensor or plug on the afm then.
Conga1991 is offline   Reply With Quote
Old 04-20-2011, 04:08 PM   #6
vbryanv
3" Exhaust
 
Join Date: Apr 2010
Location: new jersey
Posts: 57
vbryanv is on a distinguished road
Default

have you tried the idle air control valve (iac)
vbryanv is offline   Reply With Quote
Old 04-20-2011, 04:17 PM   #7
Ranma
12psi boost
 
Ranma's Avatar
 
Join Date: Jun 2010
Location: Claremore, OK
Posts: 326
Blog Entries: 10
Ranma is an unknown quantity at this point
Talking

You could always put up some money and let the dealer fix him. Sometimes we get so focused we miss the oblivious. So support your local Toyota dealer and let them correct the problem.
__________________
1986 Mk III MA70 7MGE Targa Top 5 Speed Stock Exhaust
Ranma is offline   Reply With Quote
Old 04-20-2011, 05:16 PM   #8
gloreboy89
3" Exhaust
 
gloreboy89's Avatar
 
Join Date: Aug 2010
Location: Atlanta, GA
Posts: 68
gloreboy89 is on a distinguished road
Default

seems like your better off doing a engine swap.
__________________
too lazy to find a funny quote, buuuutttt off the top of my head. "life always= how well you treat your car, put crap in ur car, then car breaks down, then miss important meeting, or work which just so happen u cant miss another day or ur fired... and end up with a crappy life.

driving an '88 supra
gloreboy89 is offline   Reply With Quote
Old 04-20-2011, 07:11 PM   #9
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Have you done a compression test?
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 04-20-2011, 08:23 PM   #10
cfurlan
Intake
 
Join Date: Oct 2010
Location: Indiana
Posts: 38
cfurlan is on a distinguished road
Default

I will do another compression test today
cfurlan is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
What turbo would give me the most power at 6-8psi supraman121 MKIII Supra 9 09-11-2007 01:45 AM
I give up... EpilepticPuppy MKIII Supra 13 09-08-2007 07:45 PM
head gasket gone would it give oil in turbo intake johnkarl MKIII Supra 7 10-31-2006 06:38 PM
Can some of you guys give me some info on these cars? Big Jimbo MKIII Supra 5 01-07-2006 08:24 PM
parts that will give me the biggest hp increases wikdMK3 MKIII Supra 6 05-04-2005 04:42 PM


All times are GMT. The time now is 01:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86