Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 05-30-2010, 12:46 AM   #1
batmmannn
12psi boost
 
batmmannn's Avatar
 
Join Date: May 2010
Location: West Virginia
Posts: 319
batmmannn is on a distinguished road
Default Hi revs no control

Hey Guys,
I test drove my Red Supra and it did fine till I gassed it or goosed it. The revs went way up and stayed up I had to kill the ignition with the Key to slow it down. After shut down and restart it did fine till I goosed it again and then the same thing happened. I brought it home and parked it.

What does this sound like? The linkage looks to be fine. Could a Vacuum problem do this? an intake leak on the plenum I just put back on? Has anyone ever seen this happen before?


Edited later.
I did a search on this forum and found someone saying that vacuum lines swapped or a vacuum leak could cause revving.

Luckily I photographed my vacuum line positions before I took it apart. I found that I had swapped lines to the Plenum. I also did not have the metal T tube hoses all clamped. Should I re-torque the Plenum bolts? Could this have caused it?

Thanks, Scott
Attached Thumbnails
Click image for larger version

Name:	supraswitched.jpg
Views:	132
Size:	88.4 KB
ID:	3081  
__________________
1987 N/A 7MGE Left Hand Drive MK3 Red 5 Speed and Black Auto Supras
My Next project is the Batmobile!


Last edited by batmmannn; 05-30-2010 at 01:30 AM. Reason: Add Info
batmmannn is offline   Reply With Quote
Old 05-30-2010, 05:08 AM   #2
907mge
20psi boost
 
907mge's Avatar
 
Join Date: Dec 2009
Location: Harrisburg
Posts: 759
907mge is on a distinguished road
Default

So unattended acceleration on a supra, sounds like a law suit, haha. The only thing I can think of is that your throttle body is sticking or the cables going to it. Because if you throttle body is closed the only place the engine can get air is from the idle speed control. And that t-pipe is your pcv which should not effect much if not clamped.
907mge is offline   Reply With Quote
Old 05-30-2010, 05:27 AM   #3
batmmannn
12psi boost
 
batmmannn's Avatar
 
Join Date: May 2010
Location: West Virginia
Posts: 319
batmmannn is on a distinguished road
Default Hi Revs

Thats cool. thanks for answering now how do I fix it???? hehe Don't think it's the cables cause if I turn the ignition off and restart then it goes back to normal till I gas it hard again. What about the plenum gasket leaking? Maybe I need to tighten the bolts more?
__________________
1987 N/A 7MGE Left Hand Drive MK3 Red 5 Speed and Black Auto Supras
My Next project is the Batmobile!


Last edited by batmmannn; 05-30-2010 at 05:30 AM.
batmmannn is offline   Reply With Quote
Old 05-30-2010, 04:54 PM   #4
907mge
20psi boost
 
907mge's Avatar
 
Join Date: Dec 2009
Location: Harrisburg
Posts: 759
907mge is on a distinguished road
Default

No its probably not the bolts, I didn't put a new gasket on when I took mine off the first time. All it did was cause a poor idle because of the unmetered air. Have someone watch the throttle underhood with the car off and someone pressing the pedal to see if the plate sticks.
907mge is offline   Reply With Quote
Old 05-30-2010, 05:51 PM   #5
batmmannn
12psi boost
 
batmmannn's Avatar
 
Join Date: May 2010
Location: West Virginia
Posts: 319
batmmannn is on a distinguished road
Default Hi Revving

Hmmm, Well I can try that but taking the motor to red line at a standstill is not something I like to do. So far it had only done it while driving. As far as the plate do you mean the butterfly inside the plenum or the throttle cable assembly? Thanks
__________________
1987 N/A 7MGE Left Hand Drive MK3 Red 5 Speed and Black Auto Supras
My Next project is the Batmobile!

batmmannn is offline   Reply With Quote
Old 05-30-2010, 09:11 PM   #6
907mge
20psi boost
 
907mge's Avatar
 
Join Date: Dec 2009
Location: Harrisburg
Posts: 759
907mge is on a distinguished road
Default

I said with the car off and yes I am talking about the throttle plate. Its a simple way to see if it is sticking.
907mge is offline   Reply With Quote
Old 05-30-2010, 11:10 PM   #7
batmmannn
12psi boost
 
batmmannn's Avatar
 
Join Date: May 2010
Location: West Virginia
Posts: 319
batmmannn is on a distinguished road
Default No Deceleration at all

Whatever it is it just got worse I have no deceleration at all now. Whatever you put the pedal at it stays at. It starts up at 3000rpm idle. Must be a problem in the plenum. Gonna have to take the air boots off and look in there. Something is very very strange here. The motor sounds great but the acceleration is a huge problem, can't be driven safely at all now. Scott
__________________
1987 N/A 7MGE Left Hand Drive MK3 Red 5 Speed and Black Auto Supras
My Next project is the Batmobile!


Last edited by batmmannn; 05-30-2010 at 11:13 PM.
batmmannn is offline   Reply With Quote
Old 05-31-2010, 12:05 AM   #8
wstanek
3" Exhaust
 
wstanek's Avatar
 
Join Date: Apr 2010
Location: Stoney Creek
Posts: 178
wstanek is on a distinguished road
Default

hey had this happen once i started it just b4 buying it and it revved and stayed at 3k so turned it off and lubed the lines and all moving throttle parts its never happened again lol. knock on wood
wstanek is offline   Reply With Quote
Old 05-31-2010, 01:58 AM   #9
batmmannn
12psi boost
 
batmmannn's Avatar
 
Join Date: May 2010
Location: West Virginia
Posts: 319
batmmannn is on a distinguished road
Default Knock on wood!

Quote:
Originally Posted by wstanek View Post
hey had this happen once i started it just b4 buying it and it revved and stayed at 3k so turned it off and lubed the lines and all moving throttle parts its never happened again lol. knock on wood
MAN YOU CALLED THE BALL! I WAS KNOCKING ON WOOD> ACORNS!
VARMITS !!!!!!

Critters had eaten through the air filter and I had a rats next of wood and acorns and crap coming up into my throttle body! GREAT!

I wonder how much garbage I sucked into the motor. Here are some pics. Problem SOLVED! Or created from dirt in the chambers. CRAP!

Yeah I know, I should have checked this! I was just in the test driving stage.....GRRRRRRRRRR!!!! The butterfly was getting trapped by acorns!
Hopefully most of what made it into the motor was twigs, leaves and acorns shoft crap. I put my shop vac into the plenum and sucked it cleanas I could. Was running good hope it keeps going.... Damn VARMITS!

Makes me feel not so sorry for the dead critters my cats bring to the door with their heads chewed off!
Attached Thumbnails
Click image for larger version

Name:	supradirt1.jpg
Views:	129
Size:	60.1 KB
ID:	3084   Click image for larger version

Name:	supradirt2.jpg
Views:	127
Size:	89.9 KB
ID:	3085   Click image for larger version

Name:	supradirt3.jpg
Views:	128
Size:	62.6 KB
ID:	3086   Click image for larger version

Name:	supradirt4.jpg
Views:	124
Size:	54.5 KB
ID:	3087  
__________________
1987 N/A 7MGE Left Hand Drive MK3 Red 5 Speed and Black Auto Supras
My Next project is the Batmobile!


Last edited by batmmannn; 05-31-2010 at 02:00 AM.
batmmannn is offline   Reply With Quote
Old 05-31-2010, 02:06 AM   #10
Green7mgte
Supra Forum Moderator
 
Join Date: Nov 2009
Location: Green-Ohio
Posts: 1,297
Green7mgte is on a distinguished road
Default

lol wow.

reminds me of a time I fell out of a tree and landed on my buddys 84 mustang.. (not 5.0) I dented the hood and made his throttle cable stick from time to time.. man it was funny to see him freak out whenever he wasn't able to stop! thank god it never got anyone hurt.
__________________

92 Ma71 7mGTE Auto. SafcII
Supra FAQ
Supra MKIII FAQ
Classified Section guidelines :

Green7mgte is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Cruise control Rob1 MKIII Supra 0 05-18-2010 05:37 PM
Mirror Control doesn't work Serge MKII Supra 0 09-22-2008 01:56 AM
Weired Cruse Control Issue Chambers MKIII Supra 4 07-01-2008 03:11 PM
Lost control of my car today. redmaro Off Topic Forum 5 01-19-2007 05:04 PM
Retractor control box is the Integration Relay No.2 Burn N' Up MKIII Supra 5 04-30-2006 09:49 PM


All times are GMT. The time now is 04:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86