Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 08-16-2022, 09:22 PM   #11
Bru
Bone Stock w Upgrades ;-)
 
Bru's Avatar
 
Join Date: Apr 2010
Location: Tampa Bay
Posts: 199
Bru is on a distinguished road
Default

Describe your particular symptoms. Does it crank but not start? Does it not crank when it's hot unless you cycle the switch many times? If that's the case then check the EFI relay behind the battery. These can go bad from heat soak and give an intermittent failing. Here is a link to the online wire diagram on the starter circuit page. http://cygnusx1.net/Supra/Library/TS....aspx?S=D&P=32

Last edited by Bru; 08-17-2022 at 03:04 PM.
Bru is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wrist pin issue -- Was: Ris pen issue KeelanWiese MKIII Supra 3 02-13-2010 07:38 PM
Sputtering Issue gorillaguy8 MKIII Supra 5 02-02-2010 09:52 PM
Overheating issue, searches suggest BHG but i'm not convinced!!! poboy69 MKIII Supra 8 05-01-2009 05:38 PM
Engine Run-on Issue gottadiesel MKIII Supra 1 04-02-2009 07:26 AM
Intermittent Electrical Problems on a í93 MKIV gjs_cds Shops & Part Reviews 0 05-22-2006 02:39 PM


All times are GMT. The time now is 04:24 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87