Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 02-12-2010, 05:32 PM   #1
KeelanWiese
Stock
 
Join Date: Feb 2010
Location: WA
Posts: 2
KeelanWiese is on a distinguished road
Default Wrist pin issue -- Was: Ris pen issue

I am thinkin about trading my old 944 for a late 80's turbo supra. he said it has some top end ticking around 3K rpms. and was told it was a ris pen issue, any ideas? serious issue? what am i getting into if i bust out the tool box
KeelanWiese is offline   Reply With Quote
Old 02-12-2010, 05:54 PM   #2
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

That would be "wrist pin"... it's the pin which holds the connecting rod to the piston. Not a common problem and as such I'm quite doubtful of the diagnosis... if it is accurate count on a full rebuild.

Have you seen this vehicle in person? Is the noise high in pitch or deep? Is it louder than a ticking clock?
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 02-12-2010, 06:01 PM   #3
KeelanWiese
Stock
 
Join Date: Feb 2010
Location: WA
Posts: 2
KeelanWiese is on a distinguished road
Default

Yeah its a good loud click in the top end, the motor was pretty well built and runs and drives well, it just gets come noise when you get up on the rpms. so a full rebuild? mmk. im not a toyota pro, though my buddies are. any other common issues it could be?
KeelanWiese is offline   Reply With Quote
Old 02-13-2010, 07:38 PM   #4
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

I just said full rebuild if it is a problem with a shot wrist pin as getting to that would require pulling the engine and the head... you'll already be half way there. You didn't even mention this was already rebuilt. What makes you think this was a well built engine? Have you listened to the noise yourself?

The "common" causes of ticking and knocking in the 7M is bad valve lash (a constant, light ticking which increases with the RPM), injector ticking (sounds a lot like the valve tick) and rod knock. It could be a wrist pin or piston slap, but they're not common. Another thing worth checking is to make sure all of the belt pulleys are securely mounted... a loose harmonic damper makes a lot of racket.

To diagnose it yourself, get a stethoscope and track the sound. If it's bottom end noise, start pulling plug wires to find which cylinder has the problem; top end, listen directly to the injectors and then pull the valve covers and inspect the cam clearances.

If you're unfamiliar with diagnosing these things you should just take it to a mechanic you trust for a solid diagnosis; Especially if this is going to be your only car.
cre is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
94 Supra TT with idling and lost of power issue bayatt MKIV Supra 4 03-12-2010 01:29 PM
Sputtering Issue gorillaguy8 MKIII Supra 5 02-02-2010 09:52 PM
Rough Idle Issue suprajim MKIII Supra 9 12-19-2009 10:35 PM
Tachometer Issue teflon44 MKIV Supra 10 09-06-2009 04:02 PM
Engine Run-on Issue gottadiesel MKIII Supra 1 04-02-2009 08:26 AM


All times are GMT. The time now is 06:47 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86