Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 03-25-2010, 06:07 AM   #1
87sup
Stock
 
Join Date: Mar 2010
Location: Portland, OR
Posts: 2
87sup is on a distinguished road
Default New to supras, got some questions.

Hey guys, i just traded my jeep straight across for a pretty clean supra. Its a 1987, non turbo, 5 speed, dark blue exterior/light blue interior. its got a few paint issues, but I'll figure that out later.

Heres a little background on me. I've owned jeeps and ford trucks almost exclusively till now. This is actually my first car, my first import, my first vehicle with A/C, etc. alot of firsts. I'm in school/interning to be a ford truck mechanic. I've built 2 jeeps, 2 '67-'72 ford trucks, and now i have myself a supra to play with.

I was told that the motor isnt original. it says "twin cam 24 valve" and "3000" on the valve cover, so I'm guessing its a DOHC 3.0L motor? its non turbo so its probably a 7mge, right?

What are some things i should look for to identify the motor?

I got more questions for you, but for now thats it.

Last edited by 87sup; 03-25-2010 at 06:35 AM.
87sup is offline   Reply With Quote
Old 03-25-2010, 05:31 PM   #2
btwilson86
Super Moderator
 
btwilson86's Avatar
 
Join Date: May 2007
Location: Billings, Montana
Posts: 1,034
btwilson86 is on a distinguished road
Default

By a different motor I wonder if the seller meant that they put another one of the same engines in it, because you are correct, a 7MGE is a 3.0L Twin Cam 24 Valve engine. Typically the timing belt cover (upper) will have the engine code right on it (7MGE or 7MGTE). Easiest way to identify it would be to post a picture of it.

Since this is a MKIII Specific post, I'll move this thread to that forum for you
__________________
1989 7MGTE R154 Targa Top White Package w/Blue Interior
Driftmotion 57trim CT26, Upgraded Intercooler, 2.25" Hard Pipes, 3" Turbo Back Exhaust with Test Pipe, HKS VPC w/GM 3 bar MAP sensor, APEXi S-AFC, Walbro 255lph fuel pump, ProSport EVO Series Boost / Fuel Pressure / AFR gauges, Lotek a Pillar Gauge Pod, HKS Type 0 Turbo Timer, Eibach Lowering Springs, Tokico Illumina II TEMS struts, custom powder coated Motegi Racing TrakLite wheels
btwilson86 is offline   Reply With Quote
Old 03-26-2010, 04:50 AM   #3
87sup
Stock
 
Join Date: Mar 2010
Location: Portland, OR
Posts: 2
87sup is on a distinguished road
Default

Alright, ill post a picture of it soon. thanks for moving this to the right section. Just got done cleaning it out and found about 4'' of water in the spare tire compartment and inside each quarter panel.

also, the heater doesn't work. it won't go to defrost, but will switch all the vent positions. it blows cold no matter what the temp setting is. the lights also dim below the point of still being able to see them when i turn the headlights on. i couldn't find a fuse for the heater on the fuse box under the hood, and the coolant is topped off.

does anyone have any idea what could be wrong?
__________________
1987 Supra, 7MGE, 5 speed, blue on blue, stock with 19's.
1969 Ford F100, 390, 4 speed, spool'd rear end, lowered 7'' <- soon to be bagged.
87sup is offline   Reply With Quote
Old 03-26-2010, 03:45 PM   #4
midwestmk2
3" Exhaust
 
midwestmk2's Avatar
 
Join Date: May 2005
Location: STL ,MO.
Posts: 206
midwestmk2 is on a distinguished road
Default

To be honest i would take it back to the guy.. In my oppinion a jeep is by far worth more than a n/a 7m MKIII anyday unless the jeep was just a rolling chassis.. Espeacially if the electronics are acting up and your finding water just puddled up in the back.. Sounds like th guy got you with a turd.. But that is just me.. Good luck with it and we all will help you all that we can if you hang on to it..
__________________
83 p-type,5spd,4;10 gears,New 86 cressida 5MGE 195hp,HKS metal head gasket,Cressida injectors,d-port intake runners,No EGR,No cat,Tweaked MAF,Custom cold air intake,Custom rear strut bar,Perfection clutch,Custom 3inch exhaust,4inch bazooka muffler,,Only 2700lbs,, COME AND GET IT!IF YOU DARE!! Please no Honduuuuhhhs!!!

http://www.cardomain.com/ride/858848/2
midwestmk2 is offline   Reply With Quote
Old 03-26-2010, 07:00 PM   #5
TurboSupera
3" Exhaust
 
Join Date: Mar 2008
Location: Garden Grove, CA
Posts: 106
TurboSupera is on a distinguished road
Default

Heater fix should be easy. There's something under the hood that can be replaced. Some guy showed me what to do and it worked. He said you can go to the junk yard and get that part off of a Camry. I had another MKiii, so I swapped them. It's a pretty quick fix as well. I'm sure someone will chime in on what it's called. If you were in Cali I'd help you fix it for free.

The water issue is probably due to the weather stripping from your taillights. Take them out and change out the weather stripping and you're good to go. Not too difficult, either. I found this out by sitting in the trunk while my wife ran a hose on top of the car and low and behold I saw where the water was coming in from. My spare tire area was pretty darn rusted as well.

I've not had a problem with either of these things since the fixes. It's been over two years.

Hope this helps.




Quote:
Originally Posted by 87sup View Post
Alright, ill post a picture of it soon. thanks for moving this to the right section. Just got done cleaning it out and found about 4'' of water in the spare tire compartment and inside each quarter panel.

also, the heater doesn't work. it won't go to defrost, but will switch all the vent positions. it blows cold no matter what the temp setting is. the lights also dim below the point of still being able to see them when i turn the headlights on. i couldn't find a fuse for the heater on the fuse box under the hood, and the coolant is topped off.

does anyone have any idea what could be wrong?
TurboSupera is offline   Reply With Quote
Old 03-27-2010, 05:37 AM   #6
MA70-3.0GT
12psi boost
 
MA70-3.0GT's Avatar
 
Join Date: Oct 2009
Location: Crewe, England
Posts: 356
MA70-3.0GT is on a distinguished road
Default

Hmm, could be you were seen coming as they say, a mile off...
That said though if the no heater thing really is just the vsv then the rest could be pretty easy too. I'd suspect the head gasket really though knowing these motors. The way to check would be to find the vsv (top of engine bulkhead, with heater hose running to and from and vac pipe on top) and first disconnect the linkage on the bottom and push the lever all the way up. This should result in permanently hot heater amd would be good news for your wallet. If no heat still i'd stop driving until youve read up on air locks and "bhg" symptoms.

Ive also found a source of water leakage to be the spoiler gaskets/seals where it mounts to the tailgate. Probably bailed 2gal out of my 1/4 panels, algae included... least it proves theyre solid!!

Best of luck & fingers crossed we have a duff heater vsv...
__________________
'89 MA70 Supra GT aero 3.0turbo JDM, Rebuilt motor, K&N intake, 3" stainless turbo-back. New turbo and braided line kit...

'89 Honda NC27 400, NC23 cams, open pipe, PC36a shock & possibly Showa USD forks...

'83 Yamaha 29R XJ750E-II, number 69 off the line, only runner in the country? Original except Koni shocks

'95 Honda PC26 CB500R, Winter hack, hateful, trying to sell it
I'm not paranoid, they really ARE after me!!!
MA70-3.0GT is offline   Reply With Quote
Old 03-27-2010, 06:36 AM   #7
Green7mgte
Supra Forum Moderator
 
Join Date: Nov 2009
Location: Green-Ohio
Posts: 1,297
Green7mgte is on a distinguished road
Default

change your thermostat for a start see if that fixes your heater issue.

http://www.ma70.com/bishop92t/techtips/index.html

compartment pics so you can locate vsv or w/e else you need names for.
__________________

92 Ma71 7mGTE Auto. SafcII
Supra FAQ
Supra MKIII FAQ
Classified Section guidelines :

Green7mgte is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Questions about Supras 93Vette MKIII Supra 7 07-13-2007 01:03 AM
New to Forum and to Supras Connvict Show n Tell 0 02-11-2007 11:38 PM
Buying a Supra, I have some questions. Ungoliant MKIII Supra 7 12-23-2006 05:17 AM
new here, few questions SoooopRa! MKIII Supra 6 08-29-2006 12:25 PM
Questions on Supras bigjdog23 Non-Generation Specific Questions 0 02-09-2005 04:10 PM


All times are GMT. The time now is 05:12 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86