Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 02-29-2008, 11:10 PM   #1
mkiiisupra
Lexus & 550's
 
Join Date: Sep 2007
Location: Las Vegas, NV
Posts: 570
Blog Entries: 1
mkiiisupra is on a distinguished road
Default P/S Problems

While turning at low speeds, or idle you can actually see the P/S pulley stop moving which causes a squeeking noise as belt skips over the pulley since its still being turned by the crank.

Dont know what would cuase this. It only happens while at idle or low speeds and turning. Driving around town, even in downtown areas at lower speeds never cuase this problem.
__________________
1990 Toyota Supra Turbo A/T
------------------------------------------------
Questions about oil? take a look http://www.supramania.com/aehaas/
mkiiisupra is offline   Reply With Quote
Old 03-01-2008, 12:34 AM   #2
jfunez
12psi boost
 
jfunez's Avatar
 
Join Date: Oct 2005
Location: georgia,usa
Posts: 338
jfunez is on a distinguished road
Default

have u made sure that the belt is properly tighten? if it is,it could be that your power steering pulley may be slipping on the pS pump shaft....
jfunez is offline   Reply With Quote
Old 03-01-2008, 12:34 PM   #3
mkiiisupra
Lexus & 550's
 
Join Date: Sep 2007
Location: Las Vegas, NV
Posts: 570
Blog Entries: 1
mkiiisupra is on a distinguished road
Default

the belt is tightened. The entire pulley is stopping. And the belt keeps moving cuasing a squeking noise as the belt skips over the non moving pulley
__________________
1990 Toyota Supra Turbo A/T
------------------------------------------------
Questions about oil? take a look http://www.supramania.com/aehaas/
mkiiisupra is offline   Reply With Quote
Old 03-01-2008, 08:35 PM   #4
h8z2luze
12psi boost
 
h8z2luze's Avatar
 
Join Date: May 2006
Location: Nor*Cal
Posts: 338
h8z2luze is on a distinguished road
Default

sounds like you need a new P/S pump
__________________
1989 Supra 7MGE MK3 5-speed project...
http://www.cardomain.com/ride/2385505
h8z2luze is offline   Reply With Quote
Old 03-01-2008, 09:27 PM   #5
mkiiisupra
Lexus & 550's
 
Join Date: Sep 2007
Location: Las Vegas, NV
Posts: 570
Blog Entries: 1
mkiiisupra is on a distinguished road
Default

have a spare... just hope'n thats not what the problem is. They dont exactly make the PS an easy to remove/install part

guess it wont be to bad >.<
__________________
1990 Toyota Supra Turbo A/T
------------------------------------------------
Questions about oil? take a look http://www.supramania.com/aehaas/
mkiiisupra is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to buy a Supra, though having some problems finding one. Cypherbku MKIV Supra 3 03-03-2009 01:45 AM
problems problems problems.... 86SupraMan MKIII Supra 5 02-04-2008 04:28 PM
Starting problems and accleration problems! alekjame22 MKIII Supra 6 03-17-2007 11:19 PM
Oil leak problems adellicson MKIII Supra 1 03-04-2007 10:11 PM
problems, problems, and problems tone loc MKIII Supra 6 09-06-2006 05:35 AM


All times are GMT. The time now is 12:37 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86