Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Closed Thread
 
Thread Tools Display Modes
Old 01-16-2006, 04:01 PM   #1
SleepyEyedMKIII
Stock
 
Join Date: Dec 2005
Posts: 15
SleepyEyedMKIII is on a distinguished road
Default POS supra...

supra suqs balls....thing is a peice of shit.....i get my shit with nothing wrong with it then 2 months later i get rodknock and the altinator keeps cutting on and off...now the alt dont work, the alt is brand new not even 3 months old....and i keep frying out the left taillight bulbs.....then the fuckin fuse box under the hood melts...i replace it and im still havin problems.....supras fuckin SUCK....theres no short anywhere btw.....the whole wire harness from the front to the back of the car was checked by a technition and no shorts....the fuse box is shitty...now is there anything i can do to this POS to fix the problems for good? or should i juss junk it n go bak to hondas.....
SleepyEyedMKIII is offline  
Old 01-16-2006, 06:40 PM   #2
j3pz
500whp yet?
 
Join Date: Nov 2005
Location: Mechanicsville, MD, US of A, 20659
Posts: 1,060
j3pz is on a distinguished road
Default

sounds kinda like some of the fuses maybe wrong??? dont have any ideas as far as the alt goes. if you think the car is a money pit *sigh* id stop messing with it then.
__________________
88 N/A w/ 5spd - stock - not running, bhg
87 turbo/targa w/ 5spd- fidanza light weight flywheel, new oem slave cylinder, apexi air filter, no ac and no heat
j3pz is offline  
Old 01-16-2006, 06:51 PM   #3
joel w
Lexus & 550's
 
joel w's Avatar
 
Join Date: Aug 2005
Location: In the shadows
Posts: 506
joel w is on a distinguished road
Default

sry to hear about the rod knock, but i disagree with your "supras sucks ballls" statement. as far as the alt, take it in and have it checked or replaced, if the voltage regulator is shot, then it can put out too much voltage and melt stuff..? just a thought. that or id take it to a different mechanic, it still could be a short somewhere thats making the alt work too hard? make sure you have the correct bulbs installed also..

sry for your grief, but hondas break down too,
joel w is offline  
Old 01-16-2006, 10:50 PM   #4
SleepyEyedMKIII
Stock
 
Join Date: Dec 2005
Posts: 15
SleepyEyedMKIII is on a distinguished road
Default

i dont understand cuz the alt isnt even 3 months old....but w/e ill put a new one in and see what happens
SleepyEyedMKIII is offline  
Old 01-16-2006, 11:11 PM   #5
GreenChevelleSS
3" Exhaust
 
GreenChevelleSS's Avatar
 
Join Date: Oct 2005
Location: okiehoma USA
Posts: 70
GreenChevelleSS is on a distinguished road
Default

its those sleepy eyes.........
__________________
1990 Toyota Supra Turbo 7M-GTE
1970 Chevrolet Chevelle SS 396
1996 Chevrolet Silverado Z71
www.cardomain.com/id/3115ultima
GreenChevelleSS is offline  
Old 01-17-2006, 12:03 AM   #6
TrDSpEeD717
Stock
 
Join Date: Jan 2006
Location: Da Bay Area FrisCo
Posts: 12
TrDSpEeD717 is on a distinguished road
Talking Supras SUCK??

Maybe it is just your supra that suck mines is running perfect.I dont mean to be rude but if you dont like supra why are you on this website n why do u have a supra??just sale it.hope everything works out for u and u come to liking supras as much as i do
TrDSpEeD717 is offline  
Old 01-17-2006, 12:23 AM   #7
joel w
Lexus & 550's
 
joel w's Avatar
 
Join Date: Aug 2005
Location: In the shadows
Posts: 506
joel w is on a distinguished road
Default

Quote:
Originally Posted by SleepyEyedMKIII
i dont understand cuz the alt isnt even 3 months old....but w/e ill put a new one in and see what happens
ive seen bad altinators right out of the box, but it sure sounds like something is drawing too much power and making it work too hard. take it back to where you bought the alt, they should test it or replace it for free if its bad...bring your reciept..
joel w is offline  
Old 01-17-2006, 07:38 AM   #8
lethalwithasupra
3" Exhaust
 
Join Date: Sep 2005
Location: south cantebury
Posts: 112
lethalwithasupra is on a distinguished road
Default

your taillight blows because there is water leaking into the boot from around the bolts holding the spoiler down. the moisture + heat kills them. my reverse lights go, sometimes brake lights. or your tail light lenses. or your rear window ( i've reglued everything back there but the window )

check the amp ratings of the fuses in the fried box against the new one, make sure no one put bigger fuses in. what did the technician check ? just a short circuit would *tik* a fuse, not melt a fusebox.

describe your alt problem ? is it starting trouble you notice later, or does the alt light come on ? this is prolly cos of the fuse box problems. loose wire or something causing the voltage drop and resistance that melts a fusebox. start with small stuff like the plugs on the back of the alt, and clean and tighten the battery terminals.

do you live in south island of new zealand ? cos if you do i have a spare alt for my supra, a spare few wiring *everything* off another clapped out supra ... and if yours is for sale cheap ... mmm sleepy eyes ...
__________________
So I bought this old Honda bike, an NSR250. Bit of a street racer, I guess. I'm told they're fast.

Delivering it home with a friend driving the Supra for the first time. I drop gears and make a scream from the twin pipes flowing down this pony's flanks and it takes off like it's tail's on fire.

I look back when the Honda gets to its tap-out and the Supra's only two lengths behind. No one I've let ride my bike has told me its slow, they've all loved the thing. That car is a good thing indeed.

Last edited by lethalwithasupra; 01-17-2006 at 07:41 AM.
lethalwithasupra is offline  
Old 01-17-2006, 04:02 PM   #9
SleepyEyedMKIII
Stock
 
Join Date: Dec 2005
Posts: 15
SleepyEyedMKIII is on a distinguished road
Default

well..i dont have wing so i dont think thats the reason my bulbs blow out....umm...also the fuse/relay box in the engine bay melted on me once...replaced it and shit was fine...then now the alt goes...but its new...ummm...my passenger side back seat gets soaked all the time and stays wet but there arent any noticable leaks in the car at ALL...and juss now the fuckin heater motor fried out....and when i press the brake the lights go on in the dash.....when i first get into my car n start it the brake lights flicker when im not touching the brake.....idk...soo much shit happened just in one week...when i got the car it was perfect....i been a supra fan for years but all these problems are makin me switch tables here...
SleepyEyedMKIII is offline  
Old 01-17-2006, 06:29 PM   #10
stumpjumper
3" Exhaust
 
Join Date: Dec 2005
Posts: 74
stumpjumper is on a distinguished road
Default

I would just sell it and either get another one, or just go back to your hondas. SOunds like your pretty pissed at this one. THey can't all be winners.
stumpjumper is offline  
Closed Thread

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Begginer to SUPRA and cars, I GOT A FREE SUPRA, PLEASE HELP!! 89MkiiiSupra Non-Generation Specific Questions 5 06-01-2010 06:48 AM
Kill Board! Isphius Show n Tell 95 01-25-2010 05:05 AM
Questions about MKIV Supra ukno0003 MKIV Supra 5 11-06-2008 10:53 AM
Dream Offer Karma_Supra MKIV Supra 22 10-17-2007 03:04 PM
new here and thinking about getting a Supra WhisPer MKIV FAQ 20 03-17-2007 01:35 PM


All times are GMT. The time now is 12:26 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87