Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 12-11-2005, 03:22 AM   #1
mike06
Stock
 
Join Date: Dec 2005
Posts: 1
mike06 is on a distinguished road
Default running crappy NEED HELP

hi Just bought a 1987 supra here: http://cgi.ebay.com/ebaymotors/87-Su...QQcmdZViewItem I have it running but once it hits about 2500 to 3000 RPMs it starts to sputter and cough, backfire and bog down. the turbo will spool up but will not boost up out of vacumn. you can here the turbo spooling just at that RPM its like the fuel is cut off or something. please help if u have any info to help me out that would be great! im sure any info that you need to know is in the link. thanks for any help.
mike06 is offline   Reply With Quote
Old 12-30-2005, 12:37 PM   #2
suprra_girl
7M POWAH! ;)
 
suprra_girl's Avatar
 
Join Date: Jun 2004
Location: New Zealand
Posts: 2,312
suprra_girl has a spectacular aura aboutsuprra_girl has a spectacular aura about
Default

hmm i seem to have missed this post somewhere

have you run a diagnostic yet?
http://www.cygnusx1.net/supra/techti...rrorcodes.html

have you checked all your intercooler pipes for leaks/cracks/splits?
does black smoke puff out the exhaust while at idle or trying to rev?

lmk bout the diagnostic codes and we'll go from there
__________________
Please use the forum to ask your questions as they will get replied to much faster than pming me

Pics of my build.

"Good girls are just bad girls that don't get caught"

Do a diagnostic first!
suprra_girl is offline   Reply With Quote
Old 12-30-2005, 01:45 PM   #3
Dboz
Stock
 
Join Date: Dec 2005
Posts: 24
Dboz is on a distinguished road
Default

Quote:
Originally Posted by mike06
hi Just bought a 1987 supra here: http://cgi.ebay.com/ebaymotors/87-Su...QQcmdZViewItem I have it running but once it hits about 2500 to 3000 RPMs it starts to sputter and cough, backfire and bog down. the turbo will spool up but will not boost up out of vacumn. you can here the turbo spooling just at that RPM its like the fuel is cut off or something. please help if u have any info to help me out that would be great! im sure any info that you need to know is in the link. thanks for any help.
have you checked the timing?.. this happened to my mr2 because toyota retarded my timing by 13 degrees.. idiots! arrgh
Dboz is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
MKIV Supra TT Daytime Running Lights?? MIX MKIV Supra 2 08-30-2007 02:52 AM
Running very rich OmeGa MKIII Supra 3 12-09-2006 09:59 PM
supra running rough finn MKIII Supra 0 09-25-2006 07:10 PM
fixed the running rich problem djalkyd MKIII Supra 6 05-04-2006 04:31 AM
87 Toy Supra N/A, Running on 4 Cylinders wilvelas MKIII Supra 5 04-24-2006 02:40 AM


All times are GMT. The time now is 12:08 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87