Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 06-05-2012, 10:41 PM   #11
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Quote:
Originally Posted by cre View Post
There should be no sound WHILE you are boosting. If there is the most common causes (as well as causes of the code 34) are: #1 boost leak, #2 bad AFM, #3 shot wastegate and #4 bad turbo.
Sounds most like a boost leak to me... a small one, hence the whistle/groan/woot sound.

I wouldn't run that filter. Gets plenty of poor reviews, a couple show-downs have shown it to perform very poorly and I've seen enough of them collapsed with bits (of just the foam) sucked into the turbo for me to go nowhere near it. But, if you like it that's fine.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 06-06-2012, 02:15 AM   #12
Spy_91
Stock
 
Join Date: Feb 2012
Location: Kansas
Posts: 8
Spy_91 is on a distinguished road
Default

Great....a small one is going to be hard to find.

That's the filter that was on the car when I bought it. I had never heard anything bad about it, so i always used it. But that makes sense that the "sponge" would fall apart and get ingested by the turbo. Might be time for a change, especially if its gonna save my turbo and add a few horses. I'm thinking just a cone w/ paper filter.... seems to be popular. Anyone know of a good one? Might be time to start a new thread
Spy_91 is offline   Reply With Quote
Old 06-06-2012, 08:09 AM   #13
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Google "diy boost leak tester".

Google "air filter show down".

Searc h on the forum for cold air intake threads or CAI or best filter... and so on. The two most popular options (and the two which typically come out on top in tests) are AEM DryFlow and Apex'i. Amsoil's air filter's are supposed to rank right up there with those other two but they as well as the Apex'i command a premium over AEM. I like the AEM for price and performance.

Whatever you get don't just leave it sucking in hot air from the engine bay, you're better off just keeping the stock box and putting in a GOOD air filter.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 06-06-2012, 12:53 PM   #14
Green7mgte
Supra Forum Moderator
 
Join Date: Nov 2009
Location: Green-Ohio
Posts: 1,297
Green7mgte is on a distinguished road
Default

4/6 psi at wot.. not on deceleration? does compression surge only happen when the throttle place closes?
__________________

92 Ma71 7mGTE Auto. SafcII
Supra FAQ
Supra MKIII FAQ
Classified Section guidelines :

Green7mgte is offline   Reply With Quote
Old 07-01-2014, 09:07 PM   #15
Spy_91
Stock
 
Join Date: Feb 2012
Location: Kansas
Posts: 8
Spy_91 is on a distinguished road
Default

Apologies for bringing back an old thread. But I resolved the problem and if anyone else has the problems listed above, hopefully this helps.

As i posted previously, my boost was cutting out at wot and I got error code 34. I replaced my stock BOV, with the Bosch and after checking every intake hose and cupler, I found no holes, cracks, or loose fittings. Since that did not fix my problem. So I went to the next suggestion, which was the wastegate actuator. After inspecting the actuator (opening up the canister) I found a small hole/crack in the rubber diaphragm. I bought a new "CT26 Wastegate Actuator" from driftmotion (which was a direct fit) and installed it. Went with the 11 psi since it was the same price as the 8 psi. Anyway....Problem solved!! No longer cuts out at wot and is able to boost to well over 5 psi (which is were it usually cut out) no more error codes, and woot/hoot sound went away.

cre - thanks for all your input. You'll be happy to know that i ditched that sponge filter and i'm currently running apexi's cone intake filter.
Spy_91 is offline   Reply With Quote
Old 08-13-2014, 07:01 PM   #16
1989stupra_targaturbo
Stock
 
Join Date: Jun 2014
Location: ontario canada
Posts: 15
1989stupra_targaturbo is on a distinguished road
Default

I've been having the very same problem... but have yet to check the actuator... hopefully all this info will come in handy. Ive had nothing but trouble with the turbo on this car since I bought it. Some days it would run fine, but most days its awful... most recently my ebc stopped working... when I flip the switch on it does nothing. My factory boost gauge is still hooked up and working, does this make any sense?
this is my second 89 with the 7m gte ...im starting to regret it!
1989stupra_targaturbo is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wastegate? Austinw88 MKIII Supra 7 06-21-2011 02:59 AM
Cold start issues??? Stanghunter MKIII Supra 1 07-19-2010 09:48 PM
Boost Issues abhattan MKIII Supra 1 04-25-2007 03:57 AM
External Wastegate! teedoff00 MKIII Supra 1 04-11-2007 04:49 AM
Wastegate? drmmr15 MKIII Supra 19 01-16-2007 07:07 PM


All times are GMT. The time now is 08:04 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86