Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 06-02-2011, 05:02 AM   #1
chuck0960
Stock
 
Join Date: May 2011
Location: St. Clair, Mo
Posts: 16
chuck0960 is on a distinguished road
Default NEEd HELp

so i just got done doing a headgasket on my 91 7mgte. i have everything on (i believe). when i turn the key on my fuel pump will no longer turn on to prime the fuel rail...but when i try to crank the motor it will pump fuel to the fuel rail. Also when i try to crank the motor i just get a weird whining noise...its a dull noise..and i cannot figure out where its coming from. i have spent a couple hours reading on here but cant get any good ideas...everyone with a starting problem can at least get it to crank over some. thanks for any help.
chuck0960 is offline   Reply With Quote
Old 06-02-2011, 02:06 PM   #2
El Supracabras
3" Exhaust
 
El Supracabras's Avatar
 
Join Date: Feb 2010
Location: Chicago
Posts: 240
El Supracabras is on a distinguished road
Default

I don't believe the fuel pump normally runs in the key on position with the engine off. Only while cranking or while the engine is running and key is in the on position, (if it is still in stock configuration).
Does the engine turn at all while cranking? The whining noise happens all the time or only while trying to start the engine? Try to isolate the noise better if possible.
Perhaps the easiest thing to check would be your actual battery voltage. Also check battery voltage while attempting to crank the engine.
El Supracabras is offline   Reply With Quote
Old 06-03-2011, 12:58 AM   #3
chuck0960
Stock
 
Join Date: May 2011
Location: St. Clair, Mo
Posts: 16
chuck0960 is on a distinguished road
Default

It ended up being the battery not having enough juice. But now it will crank and fire but not run. Can u help me with this?
chuck0960 is offline   Reply With Quote
Old 06-03-2011, 01:52 AM   #4
87hilux7mge
walbro fp
 
87hilux7mge's Avatar
 
Join Date: Dec 2010
Location: spokane
Posts: 479
87hilux7mge is on a distinguished road
Default

sounds like the circuit opening relay for the fuel pump.

when you turn the key to the on position, the fuel pump runs for a few seconds to prime the lines and fuel rail, then stops. that supplies enough fuel to get the engine to fire and once the VAFM starts seeing a signal that air is coming in, the fuel pump receives power again and begins pumping until that signal ceases.

check that and see if its hooked up. if so and operating properly, then id look at your VAFM/KVAFM
__________________
87 toyota 4x4 single cab short box pickup, 7MGZE.
87hilux7mge is offline   Reply With Quote
Old 06-03-2011, 02:07 AM   #5
chuck0960
Stock
 
Join Date: May 2011
Location: St. Clair, Mo
Posts: 16
chuck0960 is on a distinguished road
Default

Could u point me in any direction of where that circuit is located?
And could the KVAFM be why it will crank but not start up???
Patience is a virtue but man this starting to suck
chuck0960 is offline   Reply With Quote
Old 06-03-2011, 02:26 AM   #6
87hilux7mge
walbro fp
 
87hilux7mge's Avatar
 
Join Date: Dec 2010
Location: spokane
Posts: 479
87hilux7mge is on a distinguished road
Default

http://www.cygnusx1.net/Supra/Librar...px?S=Main&P=22

the KVAFM is a possibility, but ive heard of ppl start and run their cars without this even hooked up.

id say its the COR, or the fuel pump relay. u should be able to find both in the TSRM link above.
__________________
87 toyota 4x4 single cab short box pickup, 7MGZE.

Last edited by 87hilux7mge; 06-03-2011 at 02:28 AM.
87hilux7mge is offline   Reply With Quote
Old 06-03-2011, 03:26 AM   #7
chuck0960
Stock
 
Join Date: May 2011
Location: St. Clair, Mo
Posts: 16
chuck0960 is on a distinguished road
Default

ok. ill have to check that. thanks a lot. i have another question...the clips that go to the fuel injectors are white/grey and orange. does anybody know the order they should go from front to back?? i have a feeling these might be wrong but the clips can pretty much only reach a certain injector.
chuck0960 is offline   Reply With Quote
Old 06-03-2011, 04:12 AM   #8
El Supracabras
3" Exhaust
 
El Supracabras's Avatar
 
Join Date: Feb 2010
Location: Chicago
Posts: 240
El Supracabras is on a distinguished road
Default

Quote:
Originally Posted by chuck0960 View Post
It ended up being the battery not having enough juice. But now it will crank and fire but not run. Can u help me with this?
What do you mean "fire but not run"? Have you verified fuel pressure? It WILL start with the kvafm unplugged, might not rev much though. Figure out what is missing, spark? fuel? timing? Something is missing. Double check all vacuum lines and grounds too.
El Supracabras is offline   Reply With Quote
Old 06-03-2011, 04:14 AM   #9
87hilux7mge
walbro fp
 
87hilux7mge's Avatar
 
Join Date: Dec 2010
Location: spokane
Posts: 479
87hilux7mge is on a distinguished road
Default

if u unclip anything on the harness u should always tag both ends so you know where they went.

if they can only reach one injector (usually this is how the harnesses work on these motors, not guaranteed) then i would assume thats how they attach.

ive never seen different color injector clips on these motors, ive only seen green and yellow.
__________________
87 toyota 4x4 single cab short box pickup, 7MGZE.
87hilux7mge is offline   Reply With Quote
Old 06-05-2011, 12:19 AM   #10
chuck0960
Stock
 
Join Date: May 2011
Location: St. Clair, Mo
Posts: 16
chuck0960 is on a distinguished road
Default

Do I need to pull the dash to get to the circuit opening relay??
chuck0960 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT. The time now is 05:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86