Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 05-13-2011, 09:29 PM   #1
jettajay
Stock
 
Join Date: Jun 2010
Location: Las Vegas, NV
Posts: 6
jettajay is on a distinguished road
Default Diagnosis needed...engine sound

Need your diagnosis please. I'm not sure what this is, but it's the first time i'm hearing this. This is my first supra, and I tried searching if anyone else had posted a video with same kind of problem but couldn't find.. Anyway, I just had a rewiring of the knock sensors, and after the turbo wasn't working and the engine started making this sound when accelerating.

http://www.youtube.com/watch?v=14WlbCf6rYo

http://youtu.be/14WlbCf6rYo
jettajay is offline   Reply With Quote
Old 05-14-2011, 12:12 AM   #2
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Quote:
Originally Posted by jettajay View Post
after the turbo wasn't working
Care to elaborate on this?

Have you experienced any significant power loss? I can't really tell much from the video... is it rattling? Have you checked for exhaust leaks, debris in the exhaust, loose heat shields or something floating in the valve covers? Also make sure the bolts for the cam gears and the harmonic balancer are all properly torqued.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 05-14-2011, 12:39 AM   #3
jettajay
Stock
 
Join Date: Jun 2010
Location: Las Vegas, NV
Posts: 6
jettajay is on a distinguished road
Default

yes, I did experience power loss. didn't check the exhaust for debris, will check again and if there is something floating in the valve covers.
jettajay is offline   Reply With Quote
Old 05-14-2011, 12:45 AM   #4
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

What happened to the turbo?
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Reply

Tags
engine, noise, odd, sound, weird

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP!: 7MGTE engine block info needed barton MKIII Supra 1 05-19-2010 06:54 PM
HELP!: 7MGTE engine block info needed barton MKIII Supra 6 04-14-2010 10:28 PM
Engine Wiring Harness NEEDED! slowryders MKIII Supra 4 07-04-2008 08:59 PM
Well crap! Advice needed with shot engine finaltable MKIII Supra 10 03-13-2008 07:35 PM


All times are GMT. The time now is 12:06 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86