Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 06-24-2010, 10:12 PM   #1
steve0490
Stock
 
Join Date: Jun 2010
Location: mahopac
Posts: 24
steve0490 is on a distinguished road
Default motor hiccup (sounds almost liek a miss)

my motor has a hicup at an idle at random times, sounds almost like a miss but is to random to be a miss, also sometimes the bogs between 2500,3000 rpm any ideas what could be the malfunction
steve0490 is offline   Reply With Quote
Old 06-25-2010, 01:27 AM   #2
CanadianBak'inSupra
Official hall monitor / search nazi - NO SOUP FOR YOU!
 
CanadianBak'inSupra's Avatar
 
Join Date: Oct 2009
Location: Canada, BC
Posts: 837
CanadianBak'inSupra is on a distinguished road
Default

im sure some one exerienced here could help you with this problem but you need to give more information...

do you have any headers or k&N

check your fuses check your vacuum CHECK FOR ERROR CODES

there is links every where for the supra only repair manual
fine error codes and follow the steps
__________________
1984 supra - 1uzfe - w58 - 4.10 - 1 piece aluminum shaft.
CanadianBak'inSupra is offline   Reply With Quote
Old 06-30-2010, 09:03 AM   #3
steve0490
Stock
 
Join Date: Jun 2010
Location: mahopac
Posts: 24
steve0490 is on a distinguished road
Default

found it never in a million years would i guess this my valve cover has the tiniest leak and the wiring harness was sitting right ontop of where the oil comes out and the oil soaked the wiring harness and followed it all the way to ecu and soak all the plugs on the ecu how crazy is that
steve0490 is offline   Reply With Quote
Old 06-30-2010, 02:21 PM   #4
CanadianBak'inSupra
Official hall monitor / search nazi - NO SOUP FOR YOU!
 
CanadianBak'inSupra's Avatar
 
Join Date: Oct 2009
Location: Canada, BC
Posts: 837
CanadianBak'inSupra is on a distinguished road
Default

wow dude that sucks....
so do you now need a new ecu??
i suggest opening up the harnnes and cleaning the oil off.
you can buy the special wrap stuff from an auto parts store...
__________________
1984 supra - 1uzfe - w58 - 4.10 - 1 piece aluminum shaft.
CanadianBak'inSupra is offline   Reply With Quote
Old 07-01-2010, 04:16 PM   #5
steve0490
Stock
 
Join Date: Jun 2010
Location: mahopac
Posts: 24
steve0490 is on a distinguished road
Default

No the ecu is still good cleaned the wiring harness plugs and the ecu and now its fine had to drill two holes in the cowl to keep the wirring harnes above the valve cover but its all good now
steve0490 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Stange Miss (2000-2500 RPM) slader99 MKIII Supra 2 06-02-2008 06:23 PM
supra problems weird sounds please help Donovan MKIII Supra 13 05-12-2007 07:34 AM
Car sounds like CRAP! PsychoDad MKIII Supra 2 05-30-2006 12:06 PM


All times are GMT. The time now is 12:41 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86