Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 05-12-2007, 03:15 AM   #1
Donovan
Stock
 
Join Date: Apr 2007
Location: Burlington,WA
Posts: 21
Donovan is on a distinguished road
Default supra problems weird sounds please help

ok well i have been a proud owner of a 1987 toyota supra for about 2 an a half months now the following mods it has is a new hks non catback exauhst 3" in diameter all the way, new synchros on the tranny, engine rebuilt about 20k ago turbo running at about to 11-12 psi


well on to the weird sounds that i am receving from my car well i was being a dick to my car the other day and well i was going about 55-60 mph and hit about 8 pot holes in a rown going about that speed and so i just litterally stomped on my brakes to where i was just sliding on the rocks well then atfer that the car was fine but then when i parked it to take a break for a few i went back to it and starte dit back up and now when i put my car into reverse and move it backwards i can here like this sound coming from what sounds like the front right of the engine bay and it sounds like air being pushed out like a wooshing sound but no squealing or anyhting like that and the other problem i have is that sometimes when i go into my first gear to get moving my car will sometimes jerk and or stuter when it gets mvoing
well if you guys would have any information to help me out on this problem itwould be really appreciated
Donovan is offline   Reply With Quote
Old 05-12-2007, 04:05 AM   #2
redmaro
walbro fp
 
Join Date: Mar 2006
Location: arizona
Posts: 432
redmaro is on a distinguished road
Default

That sound maybe an exhaust leak. Are you getting a check engine Light?
__________________
MK3, Auto, Turbo.
redmaro is offline   Reply With Quote
Old 05-12-2007, 04:07 AM   #3
Donovan
Stock
 
Join Date: Apr 2007
Location: Burlington,WA
Posts: 21
Donovan is on a distinguished road
Default

no i have no check engine light at all all this just strted happning all of the sudden when i was being hard on it that one day
__________________
Nash™
www.myspace.com/devoted_seth07
Donovan is offline   Reply With Quote
Old 05-12-2007, 04:28 AM   #4
Number_Sixx
Stock
 
Number_Sixx's Avatar
 
Join Date: Feb 2007
Location: jamaica
Posts: 18
Number_Sixx is on a distinguished road
Default

sounds like boost leaking from the intercooler plumbing. Check all plumbing connections. And please don't treat the Supra like that again dude.
Number_Sixx is offline   Reply With Quote
Old 05-12-2007, 04:31 AM   #5
Donovan
Stock
 
Join Date: Apr 2007
Location: Burlington,WA
Posts: 21
Donovan is on a distinguished road
Default

alright ill make sure to check that and thanks for your help but i was wondering when i was finished cleaning out my engine bay i was being dumb and overlooked that i hadnt plugged one of my spark plugs back in and the car ran for about 5 minutes til i remebered is that going to have any harsh effects on my car and the reason it was taken out is cause water got down into that area and i was trying to get most of it out cause my car was acting horrible when it got own in there the was just putting when i pushed the gas and it felt like lots of power was being lost
__________________
Nash™
www.myspace.com/devoted_seth07
Donovan is offline   Reply With Quote
Old 05-12-2007, 04:43 AM   #6
Number_Sixx
Stock
 
Number_Sixx's Avatar
 
Join Date: Feb 2007
Location: jamaica
Posts: 18
Number_Sixx is on a distinguished road
Default

Quote:
Originally Posted by Donovan
alright ill make sure to check that and thanks for your help but i was wondering when i was finished cleaning out my engine bay i was being dumb and overlooked that i hadnt plugged one of my spark plugs back in and the car ran for about 5 minutes til i remebered is that going to have any harsh effects on my car and the reason it was taken out is cause water got down into that area and i was trying to get most of it out cause my car was acting horrible when it got own in there the was just putting when i pushed the gas and it felt like lots of power was being lost
ohhh.......that will cause a misfire. Nah it will not affect the engine in a negative way, jus that particular cylinder is not getting any spark to make power and the other 5 cylinders are somewhat under undue strain. .Yeah you will feel some power lost and the car behaves really sluggish and sounds awful.
Number_Sixx is offline   Reply With Quote
Old 05-12-2007, 04:45 AM   #7
Donovan
Stock
 
Join Date: Apr 2007
Location: Burlington,WA
Posts: 21
Donovan is on a distinguished road
Default

alright well thanks for you rlp i really appreciate it ill make sure to check the intercooler piping though i hope thats what it is but now all i got to do is figure out what up with my clutch or my tranny
__________________
Nash™
www.myspace.com/devoted_seth07
Donovan is offline   Reply With Quote
Old 05-12-2007, 04:51 AM   #8
Number_Sixx
Stock
 
Number_Sixx's Avatar
 
Join Date: Feb 2007
Location: jamaica
Posts: 18
Number_Sixx is on a distinguished road
Default

Quote:
Originally Posted by Donovan
alright well thanks for you rlp i really appreciate it ill make sure to check the intercooler piping though i hope thats what it is but now all i got to do is figure out what up with my clutch or my tranny

ummmmmm........your car is automatic or stick shift?? reason I ask is because you mentioned both clutch and tranny so I dunno which is which if you know what I mean......LOL. But yeh state the problems with the tranny and I will see if I can be of help.
Number_Sixx is offline   Reply With Quote
Old 05-12-2007, 04:53 AM   #9
Donovan
Stock
 
Join Date: Apr 2007
Location: Burlington,WA
Posts: 21
Donovan is on a distinguished road
Default

ok well it is a manul 5spd and the type of clutch i have is an ACT racing clutch well after i had abused my car say when i go into reverse or into first and get the car to startmoving it will make like a pop sound right when it moves and sometimes it feels like it will struggle to get going
__________________
Nash™
www.myspace.com/devoted_seth07
Donovan is offline   Reply With Quote
Old 05-12-2007, 05:25 AM   #10
Number_Sixx
Stock
 
Number_Sixx's Avatar
 
Join Date: Feb 2007
Location: jamaica
Posts: 18
Number_Sixx is on a distinguished road
Default

Quote:
Originally Posted by Donovan
ok well it is a manul 5spd and the type of clutch i have is an ACT racing clutch well after i had abused my car say when i go into reverse or into first and get the car to startmoving it will make like a pop sound right when it moves and sometimes it feels like it will struggle to get going
is it a 4 puck or 6 puck clutch?? sprung or solid hub??
man those racing clutches are hard on gearboxes, oh btw did you break in the clutch before pressuring the car hard??
Number_Sixx is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Want to buy a Supra, though having some problems finding one. Cypherbku MKIV Supra 3 03-03-2009 01:45 AM
Dream Offer Karma_Supra MKIV Supra 22 10-17-2007 04:04 PM
weird sounds when car moves Donovan MKIII Supra 10 06-09-2007 12:14 AM
Supra Wiring/Fuse Problems Need Help!!! Kristamarie Non-Generation Specific Questions 10 12-12-2005 02:11 AM
small problems with 85 supra... castle77 Non-Generation Specific Questions 0 09-07-2005 06:48 AM


All times are GMT. The time now is 12:44 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86