Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 07-24-2009, 11:54 PM   #1
venomstreetmachine
Banned
 
Join Date: Jun 2009
Location: Abilene Tx
Posts: 10
venomstreetmachine is on a distinguished road
Question Boost problems please help

I just installed a new head with new Titan 2mm gasket.
I figured i would upgrade the exhaust manifold and turbo.
I got a Super T4 and a turbo XS exhaust for my 90 Supra 7MGTE
I installed the head and the manifold, added a Tial 50 mm wastegate
3" v-Band and exhaust pipe. Wastegat vents to Atmosphere.
Also put on a BOV.
The car starts and runs great at idle. I cant hear the turbo,when I stomp on it and release, i should hear the BOV go whooosh but nothing.
The turbo doesnt seem to spool all thou it is turning.
I have an aftermarket boost guage and shows me -10 when I accelerate it goes to 0 but no boost !
I have no leaks but no boost anyone have a clue?
venomstreetmachine is offline   Reply With Quote
Old 07-26-2009, 07:05 PM   #2
corrosivecopper
Stock
 
Join Date: Jul 2009
Location: Bonnyville, Alberta, Canada
Posts: 20
corrosivecopper is on a distinguished road
Default

You may have a vac line or something. Or, when something like that happened to me in my 89 Daytona turbo, the c clip slipped off the rod for the wastegate so it wasn't allowing the turbo to build boost. Put it back together and it worked fine. A lot of the times, the simplest solution fixes the problem. Check the easy things first and go from there. Hope that help ya a little
corrosivecopper is offline   Reply With Quote
Reply

Tags
boost, exhaust, leak, psi, turbo

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
low boost psi, wtf supradad86_5 MKIII Supra 4 02-09-2014 03:05 AM
1991 turbo automatic BOOST problems tomlin1061 MKIII Supra 1 03-24-2007 01:19 AM
issue w/ boost spikes? i think? NOTORIOUS VR Non-Generation Specific Questions 17 01-17-2007 08:35 PM
Boost problems! chrish6323 MKIII Supra 9 10-07-2006 06:16 AM
Blitz Elec Boost Controller Problems HELP for 1-GTE azzurro MKIII Supra 1 10-04-2005 12:41 PM


All times are GMT. The time now is 10:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86