Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 12-09-2008, 08:03 PM   #1
dieseltech24179
3" Exhaust
 
Join Date: Oct 2008
Location: vinton
Posts: 57
dieseltech24179 is on a distinguished road
Default Afm questions

Hey guys I'm getting the code that says afm circuit or afm. I forget which code it is but I know its not the circuit cuz the car has a new engine harness. Should I just replace it back to stock or go o n ahead and get the lexus afm? I want to run higher boost pressure later on which then ill get the 550 injectors and an fpr and afr. All this seems confusing cuz I don't want to install something and have it set wrong and mess something up. I guess all I'm asking for is a little advice and some tips on how to do this right. Thanks
dieseltech24179 is offline   Reply With Quote
Old 12-10-2008, 07:37 AM   #2
ravenmaster
12psi boost
 
ravenmaster's Avatar
 
Join Date: Aug 2006
Location: Being not duly informed, I refuse to answer with any degree of accuracy for fear of prevaricating
Posts: 265
ravenmaster is on a distinguished road
Default

Well I run the Lexus AFM/ 550cc injector mod and couldnt be happier. Only problem is that if your getting that code is, since you have to use the housing (the black electronic peice on top.) from the original Supra AFM, your gunna have to buy that too since that is most likely the problem currently.
__________________
1988 Toyota Supra Turbo Targa
Tokico Illumina II's (TEMS) | Eibach Pro Springs | SpeedTech AntiSway Bars | Cusco Strut Tower Bars | Lexus AFM/550cc Injector Mod | SOGI short shift mod | Aluminum Driveshaft | Upgraded Fuel Pump | 12 PSI Boost | MHG | 11/30/08 Dyno 362RWHP 326ft/lb


Quote:
Originally Posted by supramacist View Post
Ya I'm the a$$hole. I think you're still mad raven cause I thought from your handle that you were a chick. I said I was sorry for that.
ravenmaster is offline   Reply With Quote
Old 12-10-2008, 08:34 AM   #3
dieseltech24179
3" Exhaust
 
Join Date: Oct 2008
Location: vinton
Posts: 57
dieseltech24179 is on a distinguished road
Default Afm

Alright well now its not showing the code. It all started with 5 codes being flashed the afm one being one of them. So I pulled the efi fuse hoping that it would clear them and it cleared all but two the afm code and the throttle position sensor one. But after I put new spark plugs in it and ran it for a day I let it sit for 1 day and when I went back out there to start it it wouldn't start. Ok so I checked codes again still the same two codes. Now 3 days later as of 3 min ago it fired right up idled a lil high from it being cold then idled rough and fluxuated a little bit. And while it was running the engine light didn't come on? I think this cars possesed? Sorry to get off track but this afm code is driving me insane.
dieseltech24179 is offline   Reply With Quote
Old 12-10-2008, 06:36 PM   #4
ravenmaster
12psi boost
 
ravenmaster's Avatar
 
Join Date: Aug 2006
Location: Being not duly informed, I refuse to answer with any degree of accuracy for fear of prevaricating
Posts: 265
ravenmaster is on a distinguished road
Default

If your saying its fluctuating while idling it could very likely be your AFM. Your engine might be getting too much or not enough air.
__________________
1988 Toyota Supra Turbo Targa
Tokico Illumina II's (TEMS) | Eibach Pro Springs | SpeedTech AntiSway Bars | Cusco Strut Tower Bars | Lexus AFM/550cc Injector Mod | SOGI short shift mod | Aluminum Driveshaft | Upgraded Fuel Pump | 12 PSI Boost | MHG | 11/30/08 Dyno 362RWHP 326ft/lb


Quote:
Originally Posted by supramacist View Post
Ya I'm the a$$hole. I think you're still mad raven cause I thought from your handle that you were a chick. I said I was sorry for that.
ravenmaster is offline   Reply With Quote
Old 12-10-2008, 07:24 PM   #5
dieseltech24179
3" Exhaust
 
Join Date: Oct 2008
Location: vinton
Posts: 57
dieseltech24179 is on a distinguished road
Default Afm

Well that's true but just an hour ago I went out to try to start it again cuz it fired right up at 3 this morning and it didn't start at like 1230 pm so could that be the afm too or ignition timing
dieseltech24179 is offline   Reply With Quote
Old 12-10-2008, 11:04 PM   #6
dieseltech24179
3" Exhaust
 
Join Date: Oct 2008
Location: vinton
Posts: 57
dieseltech24179 is on a distinguished road
Default Afm

I diagnosed the codes I know what to fix to fix the codes now it just starts up when it wants to. I think maybe there's an intermittant problem in my coil packs or would the afm cause it to start sometimes then not? Or could ignition timing be the problem here?
dieseltech24179 is offline   Reply With Quote
Old 12-11-2008, 10:45 AM   #7
ravenmaster
12psi boost
 
ravenmaster's Avatar
 
Join Date: Aug 2006
Location: Being not duly informed, I refuse to answer with any degree of accuracy for fear of prevaricating
Posts: 265
ravenmaster is on a distinguished road
Default

Yes, the AFM could cause those problems. Anyway The ignition timing I doubt is a problem because the computer automatically adjusts that.
__________________
1988 Toyota Supra Turbo Targa
Tokico Illumina II's (TEMS) | Eibach Pro Springs | SpeedTech AntiSway Bars | Cusco Strut Tower Bars | Lexus AFM/550cc Injector Mod | SOGI short shift mod | Aluminum Driveshaft | Upgraded Fuel Pump | 12 PSI Boost | MHG | 11/30/08 Dyno 362RWHP 326ft/lb


Quote:
Originally Posted by supramacist View Post
Ya I'm the a$$hole. I think you're still mad raven cause I thought from your handle that you were a chick. I said I was sorry for that.
ravenmaster is offline   Reply With Quote
Old 12-11-2008, 10:52 AM   #8
dieseltech24179
3" Exhaust
 
Join Date: Oct 2008
Location: vinton
Posts: 57
dieseltech24179 is on a distinguished road
Default Afm

Ok well I'm going to at least check my ignition timing when its running if it runs. I didn't know that an afm could possibly prevent my car from running sometimes and other times fire right up. I was also thinking maybe my coil packs are getting low resistance?? Maybe something in there could cause it not to start?? I'm just guessing there tho just in case I get an afm for it and it doesn't help it out. I want to drive it around and back and forth places but its got to start everytime first man its driving me crazy to see it just sitting there lol I hope this works
dieseltech24179 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
a few questions about the mkIV supra :D:D bad.boy MKIV Supra 4 09-17-2008 01:27 PM
Buying a Supra, I have some questions. Ungoliant MKIII Supra 7 12-23-2006 05:17 AM
Need your gus help- a few questions ravenmaster MKIII Supra 10 10-21-2006 09:59 PM
new here, few questions SoooopRa! MKIII Supra 6 08-29-2006 11:25 AM
newbie questions erik MKIII Supra 4 01-10-2006 11:37 AM


All times are GMT. The time now is 08:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86