Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 03-27-2008, 05:34 AM   #1
kwayne
Stock
 
Join Date: Mar 2008
Location: Atlanta Ga
Posts: 5
kwayne is on a distinguished road
Default No Start Hot

I have an 87 7mgte. When cold, it starts and runs fine as long as the ignition is not turned off. Once it's turned off, it has to cool down before it will start again.

I have found two ways to start the car hot. It can be roll started, or it can be started by bypassing the efi main relay with a jumper wire. So far I have replaced the ignitor, ecu, fuel pump, fuel filter, cam position sensor and coil pack. All vacume line have been replaced and all leaking moulded hoses have been replaced.

Does anyone have any ideas?
kwayne is offline   Reply With Quote
Old 04-02-2008, 09:18 AM   #2
bunksbbq
Stock
 
Join Date: Jun 2007
Location: Honolulu
Posts: 2
bunksbbq is on a distinguished road
Default

Check the neutral switch. Its located on the transmission, close to the exhust pipes. The heat will cause it to fail, preventing the starter working. After it cools off, the car will start fine. Worst case, it can be bypassed but I don't recommend it. You lose the protection of not starting in gear and cruise control.
bunksbbq is offline   Reply With Quote
Old 04-02-2008, 09:32 AM   #3
CyFi6
3" Exhaust
 
Join Date: Oct 2007
Location: SLO
Posts: 234
CyFi6 is on a distinguished road
Default

Does it crank or what? Sounds like youre having issues with your EFI relay, test it and fix or replace it if its bad.
CyFi6 is offline   Reply With Quote
Old 06-10-2008, 08:02 AM   #4
kwayne
Stock
 
Join Date: Mar 2008
Location: Atlanta Ga
Posts: 5
kwayne is on a distinguished road
Default No Start Hot

Thanks for all of the help! The problem turned out to be a fault ignition switch. When the car heated up, the switch would fail, causing a loss of power to the efi main relay control side circut. This in effect cuased the fuel pump to shut down. By inserting a jumper wire, bypassing the efi main relay, the car started and ran find. From there, we were able to back track to the ignition switch.
kwayne is offline   Reply With Quote
Old 06-10-2008, 08:06 AM   #5
CyFi6
3" Exhaust
 
Join Date: Oct 2007
Location: SLO
Posts: 234
CyFi6 is on a distinguished road
Default

glad to hear it worked out and you diagnosed it properly! Something a lot of people have trouble with
CyFi6 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
87 Supra won't start RNEMESiS42 MKIII Supra 3 06-25-2011 07:30 PM
Car wont start hot carfanatic89 MKIII Supra 41 03-30-2009 11:58 PM
My car decides when it wants to start carfanatic89 MKIII Supra 16 02-12-2008 07:50 PM
Car Died...where to start? Jrew MKIII Supra 4 10-26-2007 03:19 PM
no start 87supraguy MKIII Supra 5 03-23-2006 07:31 AM


All times are GMT. The time now is 01:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86