Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKII Supra

Reply
 
Thread Tools Display Modes
Old 12-12-2004, 02:51 AM   #1
steve-0321
Guest
 
Posts: n/a
Default

I just got a 1984 Supra for free and it doesnt run supposedly........the last owner said he cracked the head, but i checked for coolant in the oil and none was found........anyways....i dont think its a cracked head........first off the car doesnt turn over.........it just clicks and nothing......so could this be a starter problem?....second, i need to know where the fuel pump is located?........i heard those are prone to go out ........three, does the fuel pump have to be working for the car to be able to to turn over?......any help will be appreciated
  Reply With Quote
Old 12-12-2004, 03:23 AM   #2
suprra_girl
7M POWAH! ;)
 
suprra_girl's Avatar
 
Join Date: Jun 2004
Location: New Zealand
Posts: 2,312
suprra_girl has a spectacular aura aboutsuprra_girl has a spectacular aura about
Default

hey

now i can't really help with the crack in the head problem... i can't whether it is cracked or not... what i suggest is to fix the starter first and get your fuel pump workin to make sure it's gonna turn over

no you dont need fuel to get it to crank...
first thing i suggest is to turn the motor over manually first.. make sure she's not seized... also pull out the spark plugs and see what condition they're in... have any of them got water on them? it is possible the motor is hydrolocked hence the motor just going click... so check your plugs and turn her over manually and see how she goes on that

starter motor...
if you have determined the motor isn't hydrolocked and no water on your plugs we shall now troubleshoot your starter
get a piece of wire and attach it to the small spade terminal on your starter motor (power wire) (if you want to just check if it turns over you can leave the ignition off) connect the wire you just put on the starter motor to the positive terminal of the battery... if she cranks then you have bad earths somewhere, check your battery terminals are they in good nick, check all earths and powers are connectly properly and are tight

so if she cranks nows the test to see how she runs (obviously the spark plugs need to be back in for this )
turn the key over to ignition and place the wire back on the positive terminal of the battery
if she fires then yayy... now you can troubleshoot your possible cracked head if you do have one

some mk2's i believe come with diagnostics ports.. not sure which ones or if they did even at all.. if yours does have a diagnostic box located in the engine bay get a piece of wire and jump FP and +B and listen for your fuel pump.. does it go... it should be in tank in the boot so jump those two terminals and climb under the rear and see if you can hear the fuel pump

good luck and let me know how you get on
__________________
Please use the forum to ask your questions as they will get replied to much faster than pming me

Pics of my build.

"Good girls are just bad girls that don't get caught"

Do a diagnostic first!
suprra_girl is offline   Reply With Quote
Old 12-23-2004, 03:24 AM   #3
briananh
Stock
 
Join Date: Dec 2004
Posts: 3
briananh is on a distinguished road
Default

connect a battery jumper to ensure that the vehicle is getting enough juice.. could be a dead battery. if this is already noted, please disregard message
briananh is offline   Reply With Quote
Old 03-19-2005, 06:16 AM   #4
hangsupra
12psi boost
 
Join Date: Jan 2005
Location: 209 area in cali.
Posts: 397
hangsupra is on a distinguished road
Default

welll hope you get to work by now.... too late.....for me to post it up....so yep ype.... if still need help ask again....
hangsupra is offline   Reply With Quote
Old 01-02-2010, 10:24 AM   #5
chino1123
Stock
 
Join Date: Jan 2010
Location: ma.
Posts: 8
chino1123 is on a distinguished road
Default

Quote:
Originally Posted by steve-0321 View Post
I just got a 1984 Supra for free and it doesnt run supposedly........the last owner said he cracked the head, but i checked for coolant in the oil and none was found........anyways....i dont think its a cracked head........first off the car doesnt turn over.........it just clicks and nothing......so could this be a starter problem?....second, i need to know where the fuel pump is located?........i heard those are prone to go out ........three, does the fuel pump have to be working for the car to be able to to turn over?......any help will be appreciated
fuel pump is locate inside the gas tank
chino1123 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Best year and engine Supra to buy, your thoughts please. Jpw MKIV Supra 2 11-17-2007 07:58 AM
Engine Problem Stymee14 MKII Supra 2 08-06-2007 02:17 PM
Engine problem malli Non-Generation Specific Questions 3 08-01-2006 12:44 AM


All times are GMT. The time now is 07:33 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87