Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > General Discussions > Non-Generation Specific Questions

Reply
 
Thread Tools Display Modes
Old 07-30-2006, 03:43 AM   #1
V1P3R
Intake
 
Join Date: Mar 2006
Location: CT
Posts: 40
V1P3R is on a distinguished road
Exclamation Question About Turn Signal? and a few more small Qs!

Ok last week I was installing my new headunit. I did everything as best I could, got both wiring harnesses and connected them, soldering the wires and then electrical taping them. Everything was fine, worked great. But what I noticed is it kept shorting out. I was figuring it was overheating as it was getting very hot at the back. I did some research and found out that it was supposed to be getting very hot, the rear was called a "heat dump" or something like that, it is supposed to be drawing out the heat from the head unit. So when I first got it I was messing around with it while it was on and the car was on and all of a sudden it shorts out and my dash lights go out. Then I notice the rear taillights went out too! The headunit turned back on and worked fine. Also for some crazy reason my dash lights now work again!

Now I FINALLY got around to replacing a burnt fuse for the taillights, but the turn signal fuse is fine! Is there a relay or something I need to check? If so how do I do this?

Also anyone know what the deal is? I was just using the headunit a few days ago and I was moving it around a bit since the bracket/harness that is supposed to hold it in (I bought the aftermarket custom fixture since stock is double din) doesnt fit. And all of a sudden it sparked a bit, so I moved it around a little more and it made a pretty BIG spark and the player shut off. Now it wont turn back on! Im guessing I blew an internal fuse? The car radio fuse is not burnt out.


If anyone can help I greatly appreciate it! I think there is some electrical power issue here and I dont want to ruin anything any further than I might have already!

Car is a 1989 Toyota Supra 5spd N/A V6



**Also the coolant warning light flashes and sometimes stays on, although the coolant is filled to the top. Is it just a sensor going bad? The car doesnt overheat, although last month or so it did overheat at about 50mph, which im guessing was due to either an air bubble in the coolant line OR a bad mixture. It hasnt overheated or ran hot since (*knock on wood*! )

Last edited by V1P3R; 07-30-2006 at 03:48 AM.
V1P3R is offline   Reply With Quote
Old 08-05-2006, 07:43 PM   #2
V1P3R
Intake
 
Join Date: Mar 2006
Location: CT
Posts: 40
V1P3R is on a distinguished road
Default

can someone anyone PLEASE!?!?! help! I have no idea where to start to get these problems fixed!
V1P3R is offline   Reply With Quote
Old 08-05-2006, 07:55 PM   #3
damdog05
12psi boost
 
damdog05's Avatar
 
Join Date: Apr 2006
Location: Georgia
Posts: 250
damdog05 is on a distinguished road
Default

i really cant help you with your problems, but before someone decides to treat you like an idoiot, i thought id mention that supras have inline 6 engines, not v6.
__________________
My cars:
85 Trans Am- Ehhh- Gone
83 Rx7- Much Better- Gone
86.5 Supra- Love- Not Gone
damdog05 is offline   Reply With Quote
Old 08-05-2006, 09:45 PM   #4
Supra2NR
1000whp postwhore
 
Supra2NR's Avatar
 
Join Date: Apr 2006
Location: Chi-Town
Posts: 1,643
Supra2NR is on a distinguished road
Default

thank damdog for that advice i remember when sumbody made that mistake

but you might wanna check the fuse for your hazard lights, cuz i noticed that with out the hazards the turn signals dont work also

hope this helps
__________________
http://www.myspace.com/supra_2nr



Into Bikes now,, apparently the supra couldnt kill me, so my zx6 might lol
Supra2NR is offline   Reply With Quote
Old 08-05-2006, 11:41 PM   #5
V1P3R
Intake
 
Join Date: Mar 2006
Location: CT
Posts: 40
V1P3R is on a distinguished road
Default

damdog05: Thanks man, I do know that I was just in a rush to type this up and had my mind on other things

supra2nr: Thanks thats probably what it is! I have my entire middle dash piece off in order to get the headunit in, and the hazards I needed to unplug in order to take the piece off, so the signals should work once I put the piece back on.


But now I need to figure out how to get this radio working!
V1P3R is offline   Reply With Quote
Old 08-06-2006, 04:35 AM   #6
damdog05
12psi boost
 
damdog05's Avatar
 
Join Date: Apr 2006
Location: Georgia
Posts: 250
damdog05 is on a distinguished road
Default

i figured that was the case, but the last guy did the same thing and had his head pretty much chewed off. good luck with the problem
__________________
My cars:
85 Trans Am- Ehhh- Gone
83 Rx7- Much Better- Gone
86.5 Supra- Love- Not Gone
damdog05 is offline   Reply With Quote
Old 08-06-2006, 09:22 PM   #7
Supra2NR
1000whp postwhore
 
Supra2NR's Avatar
 
Join Date: Apr 2006
Location: Chi-Town
Posts: 1,643
Supra2NR is on a distinguished road
Default

that guy was so close to jus leaving the forum
its amazing how we are so loyal to our engines
that a simple one-letter mistake
can get your head chewed-off in here

"its an inline 6 not a v6" lol
to newbs remember this
__________________
http://www.myspace.com/supra_2nr



Into Bikes now,, apparently the supra couldnt kill me, so my zx6 might lol
Supra2NR is offline   Reply With Quote
Old 08-08-2006, 03:58 AM   #8
burton51m
Lexus & 550's
 
burton51m's Avatar
 
Join Date: Feb 2006
Location: Canton, OH
Posts: 536
burton51m is on a distinguished road
Default

i see so many supras advertised on autotrader.com as V6's. i dont know why but it makes me frusturated. probably cuz the owner/seller knows nuthing about the car.
__________________

burton51m is offline   Reply With Quote
Old 08-08-2006, 05:45 AM   #9
Supra2NR
1000whp postwhore
 
Supra2NR's Avatar
 
Join Date: Apr 2006
Location: Chi-Town
Posts: 1,643
Supra2NR is on a distinguished road
Default

Quote:
probably cuz the owner/seller knows nuthing about the car.
more reason for you to punk the chump and tell him that this v6 aint worth s4!t
so you can lower the price lol
__________________
http://www.myspace.com/supra_2nr



Into Bikes now,, apparently the supra couldnt kill me, so my zx6 might lol
Supra2NR is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Clear Corner (Turn signal) Lights ??? jdbones Non-Generation Specific Questions 2 11-01-2007 04:41 AM
Where is Turn Signal Flasher? MKII lastbabibumr MKII Supra 1 09-05-2006 07:19 AM


All times are GMT. The time now is 04:46 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86