Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 09-26-2006, 03:23 PM   #1
grygst76
3" Exhaust
 
Join Date: Dec 2005
Location: Springfield, Massachusetts
Posts: 87
grygst76 is on a distinguished road
Default Running rich!

went to get my inspection sticker, she is all stock except cold air, anyways I failed, we have a rolling test and my HC's were thru the roof, our limit is 2.0, I did 3.9. anyone have any ideas why she is running so rich??
__________________
89 Turbo, no mods yet

5 speed mbc to 10psi
grygst76 is offline   Reply With Quote
Old 09-27-2006, 03:15 AM   #2
mrnickleye
Old Cowboys Never Die !!
 
mrnickleye's Avatar
 
Join Date: Jun 2005
Location: Mojave Desert, Calif.
Posts: 1,705
mrnickleye is on a distinguished road
Default

HC is raw, unburned fuel.
what were the CO% #s??
-very high CO% will mean running too rich

Possible areas:
-very rich mixture (black smoke)
-Engine misfires (very likely)
-cat converter bad

Rolling Test?? you mean dyno??
__________________
Had a Red 1989 N/A. Automatic. Sports Pkg. w/wing.
TEMS, and some nice MODS. Sold to a friend 10/08/08.
mrnickleye is offline   Reply With Quote
Old 09-27-2006, 04:32 AM   #3
Murd
3" Exhaust
 
Join Date: Jul 2006
Location: Vancouver, WA.
Posts: 233
Murd is on a distinguished road
Default

Guessing he means the 25mph test. Car runs under load and they check the exhaust again, like at idle.
__________________
1989 N/A Targa 5spd. Metallic Grey, w/grey interior. No mods done.
Murd is offline   Reply With Quote
Old 09-27-2006, 12:41 PM   #4
grygst76
3" Exhaust
 
Join Date: Dec 2005
Location: Springfield, Massachusetts
Posts: 87
grygst76 is on a distinguished road
Default

co2's were high as well 30.00 is the limit, I had 23.31. really sucked...
__________________
89 Turbo, no mods yet

5 speed mbc to 10psi
grygst76 is offline   Reply With Quote
Old 09-28-2006, 06:36 AM   #5
mrnickleye
Old Cowboys Never Die !!
 
mrnickleye's Avatar
 
Join Date: Jun 2005
Location: Mojave Desert, Calif.
Posts: 1,705
mrnickleye is on a distinguished road
Default

I'd get those CO% #s down for a starter. O2 sensor, AFM, other things.
__________________
Had a Red 1989 N/A. Automatic. Sports Pkg. w/wing.
TEMS, and some nice MODS. Sold to a friend 10/08/08.
mrnickleye is offline   Reply With Quote
Old 09-28-2006, 12:36 PM   #6
grygst76
3" Exhaust
 
Join Date: Dec 2005
Location: Springfield, Massachusetts
Posts: 87
grygst76 is on a distinguished road
Default

I put the new o2 sensor in and can feel the change already, but i reset the ecu and now when I am over 2000RPMS and push in the clutch, she stalls. And I hear a fluttering from the BOV, thats normal right since it is stock?? also my idle is finnally staying where it should be, before the new o2 it would be around 800 or more.
__________________
89 Turbo, no mods yet

5 speed mbc to 10psi

Last edited by grygst76; 09-28-2006 at 04:16 PM.
grygst76 is offline   Reply With Quote
Old 09-29-2006, 02:56 AM   #7
mrnickleye
Old Cowboys Never Die !!
 
mrnickleye's Avatar
 
Join Date: Jun 2005
Location: Mojave Desert, Calif.
Posts: 1,705
mrnickleye is on a distinguished road
Default

When you reset the ECU, it may take a day or 2, and a few drive cycles for it to 're-learn', and then run correctly.
__________________
Had a Red 1989 N/A. Automatic. Sports Pkg. w/wing.
TEMS, and some nice MODS. Sold to a friend 10/08/08.
mrnickleye is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Low idle and running rich Mitshiko MKIII Supra 23 10-10-2009 03:12 AM
Running Rich! Help needed mc_p0pe MKIII Supra 13 05-23-2008 01:31 AM
Running Sooooooo Rich! Help! godgaveussid MKIII Supra 4 08-29-2007 09:46 PM
Running very rich OmeGa MKIII Supra 3 12-09-2006 09:59 PM
fixed the running rich problem djalkyd MKIII Supra 6 05-04-2006 05:31 AM


All times are GMT. The time now is 07:54 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86