Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 08-15-2011, 11:30 AM   #1
krash
Stock
 
Join Date: Aug 2011
Location: MAssachusetts
Posts: 1
krash is on a distinguished road
Default New to Forum as of today..purchased 1986.5 Supra two days ago

hello everyone....just picked up a 1986. Supra w/ 118k/5sp ..from original owner....Originated in CA....(yup, CA. emissions)....extremely well taken care of.....runs excellent....

problems; the following are not working:

1. air conditioner: fan working, just blowing warm air...
2. Fact Stereo w/cassette player: not working..
3. Cruise: Dash switch light goes on...but doesn't work when applying the wheel controls...
4. Horn....nothing, nada, kaputz...

Beyond these items, it runs excellent, shifts smoothly, no leaks anywhere,
no odd noises,....clean car
Attached Thumbnails
Click image for larger version

Name:	supra 86-1.JPG
Views:	124
Size:	39.6 KB
ID:	4147   Click image for larger version

Name:	86 supra-2.JPG
Views:	123
Size:	34.1 KB
ID:	4148   Click image for larger version

Name:	1986 Supra-2.JPG
Views:	124
Size:	34.9 KB
ID:	4149  
krash is offline   Reply With Quote
Old 08-16-2011, 12:05 AM   #2
El Supracabras
3" Exhaust
 
El Supracabras's Avatar
 
Join Date: Feb 2010
Location: Chicago
Posts: 240
El Supracabras is on a distinguished road
Default

Nice car, don't krash it. I keed. Those are all common things for any old car, even more common on old supras.
If the a/c compressor doesn't engage check the fuse for the a/c first, then the refrigerant level.
Get a new stereo, stock leaves a bit to be desired even when it works.
Check the vacuum lines and wires to the cruise control servo by the brake master cylinder. Then make sure it is connected to the throttle.
If you hear a clicking under the dash when you hit the horn, it is either bad wiring to the horns or bad horns. If you hear no clicking, check the fuse.
Good luck and take your time with the car.
El Supracabras is offline   Reply With Quote
Old 08-17-2011, 03:55 AM   #3
MJG
3" Exhaust
 
MJG's Avatar
 
Join Date: Mar 2010
Location: Washington State
Posts: 125
MJG is on a distinguished road
Default

Quote:
Get a new stereo, stock leaves a bit to be desired even when it works.
supracabras makes a good point.
The stock stero, when working is OK.
Replacing it with an aftermarket unit is well advised.
MJG is offline   Reply With Quote
Old 08-17-2011, 03:28 PM   #4
Green7mgte
Supra Forum Moderator
 
Join Date: Nov 2009
Location: Green-Ohio
Posts: 1,297
Green7mgte is on a distinguished road
Default

looking at a factory supra stereo reminds me of my grandmothers rotary phone..
__________________

92 Ma71 7mGTE Auto. SafcII
Supra FAQ
Supra MKIII FAQ
Classified Section guidelines :

Green7mgte is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
1986.5 Supra hyphy MKIII Supra 1 05-27-2009 04:33 AM
Supra Forum intertwined with other Imports Adam@D and A Hot Impotrs Off Topic Forum 1 06-20-2005 12:18 PM


All times are GMT. The time now is 08:00 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86