Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 05-14-2011, 04:17 AM   #1
Spartacus
Stock
 
Join Date: Apr 2011
Location: Washington D.C.
Posts: 6
Spartacus is on a distinguished road
Unhappy Engine Stumbles when accelerating

1986 Automatic

I'm trying to figure out what is causing my engine to stumble.

I have already replaced spark plugs, rotor, distributor cap, wires.

No codes are coming up, TPS, coil are both good. Cleaned throttle body.

I'll just describe how I have been able to recreate the problem:

I'll start the engine (hot or cold), then floor it until I get to about 30 mph (engine runs fine during this part) and then I let off accelerator. Anytime I try to accelerate after that, the engine stumbles and the idle speed is erratic, even stalls sometimes if stopped at a light.

Any help is greatly appreciated! Thank you!
Spartacus is offline   Reply With Quote
Old 05-14-2011, 08:20 AM   #2
ochowdero
12psi boost
 
Join Date: Jun 2010
Location: California
Posts: 277
ochowdero is on a distinguished road
Default

might have water in the plug well,
or maf sensor i belive can cause this if its dirty..
anyone correct me if im wrong
lol
__________________
1987 supra, BLUE 7mge.. AUTO TO MANUAL SWAP..

i really want turbo
ochowdero is offline   Reply With Quote
Old 05-14-2011, 06:55 PM   #3
Sonyps307
Lexus & 550's
 
Join Date: May 2010
Location: Baltimore
Posts: 526
Sonyps307 is on a distinguished road
Default

Check for air/vacuum leaks
Sonyps307 is offline   Reply With Quote
Old 05-14-2011, 08:28 PM   #4
Spartacus
Stock
 
Join Date: Apr 2011
Location: Washington D.C.
Posts: 6
Spartacus is on a distinguished road
Default

Quote:
Originally Posted by Sonyps307 View Post
Check for air/vacuum leaks

I forgot to mention that I checked all hoses for leaks. As far as I can tell they are all good. And I had a mechanic verify that they were

They are very small stumbles most of the time. Almost like little 'hiccups' of the engine cutting out.

When it is really bad then it will actually cause it to shift late and hard in addition to the stumbles. The RPMs will just go up to about 4k or 5k before it shifts.

New transmission installed about 3 months ago, this problem has occurred before and after the transmission was replaced

Last edited by Spartacus; 05-14-2011 at 08:45 PM.
Spartacus is offline   Reply With Quote
Old 05-14-2011, 11:28 PM   #5
Sonyps307
Lexus & 550's
 
Join Date: May 2010
Location: Baltimore
Posts: 526
Sonyps307 is on a distinguished road
Default

Does it happen more when cold or hot
Sonyps307 is offline   Reply With Quote
Old 05-15-2011, 12:13 AM   #6
Spartacus
Stock
 
Join Date: Apr 2011
Location: Washington D.C.
Posts: 6
Spartacus is on a distinguished road
Default

Quote:
Originally Posted by Sonyps307 View Post
Does it happen more when cold or hot
It seems to not matter.

I just read this thing about a problem for supras being the speed sensor and the solder points attached to the odometer. Something about it not sending the correct signals to the ecu.

Does that make sense?
Spartacus is offline   Reply With Quote
Old 05-15-2011, 06:26 AM   #7
spunkenhimer
Intake
 
spunkenhimer's Avatar
 
Join Date: Feb 2008
Location: Pikeville NC.
Posts: 49
spunkenhimer is on a distinguished road
Default

there are a lot of factors that we may need to know about your car here. If its turbo then you may want to have that checked for cracks or leaks. also if its reg 7mge then could be a bhg or timing slip i'd check the timing if you can get a timing light on it. also i've heard that the 7mge gas pumps go out pretty easily sometimes.
if you can do a diagnostic check on the car this may help

http://www.cygnusx1.net/Supra/Library/TSRM/MK3/

the diagnostic specs are in there somewhere.
spunkenhimer is offline   Reply With Quote
Old 05-15-2011, 07:27 AM   #8
mof920
Stock
 
Join Date: Nov 2010
Location: Riverside, CA
Posts: 7
mof920 is on a distinguished road
Default

My engine would stumble a lot until I realized it was a BHG. You might want to check that out. Check oil, steam in exhaust, etc. Could be the tranny as well though. When my W58 went out.... ooooh crap. It shredded in two.
mof920 is offline   Reply With Quote
Old 05-15-2011, 03:20 PM   #9
Spartacus
Stock
 
Join Date: Apr 2011
Location: Washington D.C.
Posts: 6
Spartacus is on a distinguished road
Default

Quote:
Originally Posted by spunkenhimer View Post
there are a lot of factors that we may need to know about your car here. If its turbo then you may want to have that checked for cracks or leaks. also if its reg 7mge then could be a bhg or timing slip i'd check the timing if you can get a timing light on it. also i've heard that the 7mge gas pumps go out pretty easily sometimes.
if you can do a diagnostic check on the car this may help

http://www.cygnusx1.net/Supra/Library/TSRM/MK3/

the diagnostic specs are in there somewhere.
Thanks for your reply

The car is not turbo. I just had and engine tune-up last week so I dont think its a bhg or timing, I like the mechanic, I assume he would check those things.

Could be the gas pump, do you know how I could check for that?

The diagnostic isnt throwing any codes
Spartacus is offline   Reply With Quote
Old 05-15-2011, 03:22 PM   #10
Spartacus
Stock
 
Join Date: Apr 2011
Location: Washington D.C.
Posts: 6
Spartacus is on a distinguished road
Default

Quote:
Originally Posted by mof920 View Post
My engine would stumble a lot until I realized it was a BHG. You might want to check that out. Check oil, steam in exhaust, etc. Could be the tranny as well though. When my W58 went out.... ooooh crap. It shredded in two.
Thanks, I'll check those things but I dont think its a bhg.

The car has a new tranny, just put in a few months ago and the problem happened before and after it was put in
Spartacus is offline   Reply With Quote
Reply

Tags
engine, hesitation, idle, stall, stumble

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Help! born2drv MKIII Supra 9 02-01-2011 08:14 PM
rebuilt hard to crank (high engine resistance); need advice cbrewster MKIII Supra 4 09-28-2009 05:52 PM
problem seperating engine from manual tranny Gengus MKIII Supra 7 01-29-2008 12:10 AM
subtle shuttering when accelerating on a brand new engine suprascoot MKIII Supra 2 07-24-2007 12:27 PM


All times are GMT. The time now is 09:42 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86