Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 09-26-2010, 12:12 AM   #1
kingison
Intake
 
kingison's Avatar
 
Join Date: Sep 2010
Location: phoenix
Posts: 39
Blog Entries: 1
kingison is on a distinguished road
Default A/C Fuse 90 Supra Non Turbo Auto Tranny

For some reason my car went from blowing ice cold air to stopping completely. When I engage the heater, the air is the same as when I have the a/c on. I am assuming to start with the fuse. I can't locate it.

I tried the driver's side kick panel but I dont see a fuse for a/c. On the passenger side I removed the kick panel and found an electronic transmission control box instead of a fuse box the repair manual indicates.

Under the hood, none of the fuses indicate a/c.

help
kingison is offline   Reply With Quote
Old 09-26-2010, 02:32 AM   #2
kingison
Intake
 
kingison's Avatar
 
Join Date: Sep 2010
Location: phoenix
Posts: 39
Blog Entries: 1
kingison is on a distinguished road
Default

nevermind, I had to remove the ECT and the fuse was burried way up behind. Somehow I twisted my arm to get to it and switched it out.... thanks
kingison is offline   Reply With Quote
Reply

Tags
a/c, fuse

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT. The time now is 11:36 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86