Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 05-24-2010, 04:56 PM   #1
wstanek
3" Exhaust
 
wstanek's Avatar
 
Join Date: Apr 2010
Location: Stoney Creek
Posts: 178
wstanek is on a distinguished road
Smile Now drivable

so i just took my supra out for a spin and everything went ok for first time driving a standard however i let out to quick lol but its my first car and im only 16 need get better!

i was wondering the amount of pedal movement everyones clutch has from the time it engages to when u can let it go because my clutch grabs real quick after it starts to engage. also it feels like a new clutch because there is not a lot of dead zone!

Last edited by wstanek; 05-24-2010 at 10:33 PM.
wstanek is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
no boost gmansupra Non-Generation Specific Questions 1 08-29-2009 10:59 PM


All times are GMT. The time now is 05:09 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2022, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87