Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 05-07-2010, 05:49 PM   #1
tak2099
3" Exhaust
 
tak2099's Avatar
 
Join Date: Jul 2007
Location: ohio
Posts: 90
tak2099 is on a distinguished road
Default 1800 rpm cut off

What causes the car to cut out at 1800 rpms? When idling i can rev it past 1800, but while driving, it will not go past 1800. Im assuming its some kind of fuel cut off. But my question is what are all of the different elements that could cause this? Also the MIL is not on.
__________________
1988 supra turbo. In process of modding:Roll cage, seats, dp, 3" intercooler, fuel upgrades, and turbo upgrades next.
tak2099 is offline   Reply With Quote
Old 05-07-2010, 06:08 PM   #2
TripleC
3" Exhaust
 
TripleC's Avatar
 
Join Date: Nov 2009
Location: Fort Collins, CO
Posts: 103
TripleC is on a distinguished road
Default

Boost leak. Dose the engine rev or NO?
Check your battery!
Check your Spark Plugs
__________________
1JZGTE ,R154, Hallman Boost Controller, HKS bov, HKS Mushroom top Air Filter, HKS Front Mount Intercooler, Greedy Turbo Timer, PLX300 AFC, Custom Divorced Y-pipe, Custom Intercooler Pipeing, RS-R Concept Exhaust, Optima Red Top Battery, Strut bar Brembo Rotors, A1 Traction arms, Megan Coilovers, Stern ST 2 wheels rear 265x30 r19 - front 245x35 r19, New Front Lip, 18 x 8 and 18 x 9 MRR HR2 with whatever for Drift treads
2 additional C12A turbo's(Extra)
TripleC is offline   Reply With Quote
Old 05-07-2010, 06:18 PM   #3
tak2099
3" Exhaust
 
tak2099's Avatar
 
Join Date: Jul 2007
Location: ohio
Posts: 90
tak2099 is on a distinguished road
Default

Battery?!?
It does rev, it actually idles very smooth, and will run just amazing until 1800 rpms.
And the spark plugs are brand new....along with everything else.
Could timing cause this? because i havent times it since i put the head back on.
__________________
1988 supra turbo. In process of modding:Roll cage, seats, dp, 3" intercooler, fuel upgrades, and turbo upgrades next.
tak2099 is offline   Reply With Quote
Old 05-07-2010, 06:32 PM   #4
TripleC
3" Exhaust
 
TripleC's Avatar
 
Join Date: Nov 2009
Location: Fort Collins, CO
Posts: 103
TripleC is on a distinguished road
Default

OHH hell yeah if oyu havnt timed it this is probably your problem. The battery connections can cause all kinds off issues as well.I just encountered this problem so i am fresh off shitty connection problems causeing detonation and power issues
__________________
1JZGTE ,R154, Hallman Boost Controller, HKS bov, HKS Mushroom top Air Filter, HKS Front Mount Intercooler, Greedy Turbo Timer, PLX300 AFC, Custom Divorced Y-pipe, Custom Intercooler Pipeing, RS-R Concept Exhaust, Optima Red Top Battery, Strut bar Brembo Rotors, A1 Traction arms, Megan Coilovers, Stern ST 2 wheels rear 265x30 r19 - front 245x35 r19, New Front Lip, 18 x 8 and 18 x 9 MRR HR2 with whatever for Drift treads
2 additional C12A turbo's(Extra)
TripleC is offline   Reply With Quote
Old 05-07-2010, 07:11 PM   #5
tak2099
3" Exhaust
 
tak2099's Avatar
 
Join Date: Jul 2007
Location: ohio
Posts: 90
tak2099 is on a distinguished road
Default

well, turns out its my tps.... finally got it to give me a code...which was 41. so now i have to figure out how the hell to deal with this nissan tps.
__________________
1988 supra turbo. In process of modding:Roll cage, seats, dp, 3" intercooler, fuel upgrades, and turbo upgrades next.
tak2099 is offline   Reply With Quote
Old 05-08-2010, 02:15 AM   #6
kamikazemkiii
3" Exhaust
 
Join Date: Mar 2009
Location: raleigh
Posts: 138
kamikazemkiii is on a distinguished road
Default

did you hook up the coils and wires the correct way?
kamikazemkiii is offline   Reply With Quote
Old 05-08-2010, 03:34 AM   #7
tak2099
3" Exhaust
 
tak2099's Avatar
 
Join Date: Jul 2007
Location: ohio
Posts: 90
tak2099 is on a distinguished road
Default

Yes the coils and wires are hooked up correctly. Ok, so I wired the stock tps back up, and modified my 80mm TB to use the stock one. Now it does go past 1800 rpms, BUT it still cuts out, but now its random. At WOT it goes just fine, but under normal driving it will randomly cut out. Do you guys think maybe my tps isnt adjusted right? Or maybe if my timing was off it could cause this? Or are both of those not things that would cause a random shut off?
__________________
1988 supra turbo. In process of modding:Roll cage, seats, dp, 3" intercooler, fuel upgrades, and turbo upgrades next.
tak2099 is offline   Reply With Quote
Old 05-08-2010, 04:54 AM   #8
kamikazemkiii
3" Exhaust
 
Join Date: Mar 2009
Location: raleigh
Posts: 138
kamikazemkiii is on a distinguished road
Default

could be the tps
kamikazemkiii is offline   Reply With Quote
Old 05-08-2010, 07:18 AM   #9
Semper_Fi
3" Exhaust
 
Semper_Fi's Avatar
 
Join Date: Apr 2010
Location: Kissimmee, FL
Posts: 72
Semper_Fi is on a distinguished road
Default

Quote:
Originally Posted by tak2099 View Post
Yes the coils and wires are hooked up correctly. Ok, so I wired the stock tps back up, and modified my 80mm TB to use the stock one. Now it does go past 1800 rpms, BUT it still cuts out, but now its random. At WOT it goes just fine, but under normal driving it will randomly cut out. Do you guys think maybe my tps isnt adjusted right? Or maybe if my timing was off it could cause this? Or are both of those not things that would cause a random shut off?
I would start with the timing.. Take the 7mgte cover off, and check it with the timing gun... the numbers, letters should be right stationary when you check it... hope i could help...

carlos
__________________
1989 supra turbo-

uh-60 blackhawk... My life
Semper_Fi is offline   Reply With Quote
Old 05-08-2010, 10:06 PM   #10
supraflymkiii
3" Exhaust
 
supraflymkiii's Avatar
 
Join Date: Sep 2005
Location: Menasha, WI
Posts: 63
supraflymkiii is on a distinguished road
Default

He already said it was his TPS which is what I was going to say. Readjust it and it should be good to go. This was the first thing I ever had a problem with on my first Supra, so I know first hand what he's talking about.
supraflymkiii is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Please help turbocharge my Volvo 1800 VolvoHeretic MKIII Supra 6 10-21-2008 06:09 PM


All times are GMT. The time now is 08:51 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86