Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 03-23-2010, 07:29 AM   #1
MarkLinRacing
Stock
 
MarkLinRacing's Avatar
 
Join Date: Nov 2009
Location: Canada
Posts: 29
MarkLinRacing is on a distinguished road
Default Knock Sensor/Wiring

So I have my CEL light on.

Pulled the diagnosis code and said something about knock sensor or possibly knock sensor wiring.

I heard from a friend that previously owned a MKIII Supra that apparently these knock sensors on the 7MGTE like to crap out.

I don't want to fix it unless it's causing an issue, currently the car under load, off load and at idle.

Another friend mentioned that my car might be slower than it actually is because the car might be running in "safe mode" because it won't know if it's experiencing knock or not.

I'm not familiar with how these ECUS are programmed. I would appreciate any insight.

Thanks!
__________________
MarkLinRacing is offline   Reply With Quote
Old 03-23-2010, 12:42 PM   #2
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Our knock sensors are pretty robust actually. More often than not the code 52 issue is due to wiring. Search "knock sensor rewire"... and yes, it can make the car run like piss depending on just how bad it is.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 03-23-2010, 02:52 PM   #3
MarkLinRacing
Stock
 
MarkLinRacing's Avatar
 
Join Date: Nov 2009
Location: Canada
Posts: 29
MarkLinRacing is on a distinguished road
Default

Quote:
Originally Posted by cre View Post
Our knock sensors are pretty robust actually. More often than not the code 52 issue is due to wiring. Search "knock sensor rewire"... and yes, it can make the car run like piss depending on just how bad it is.
Thanks, I found a thread about knock sensor/rewiring.

I should've searched first..
__________________
MarkLinRacing is offline   Reply With Quote
Reply

Tags
cel, knock sensor, mkiii supra, pinging, wiring

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Picture Of Knock Sensor Locations ravenmaster MKIII Supra 10 01-31-2012 04:37 PM
87 Turbo knock sensor issue supraman7 MKIII Supra 5 03-05-2010 07:44 PM
Starting isssues and spark knock Q's spudz29212MKIII MKIII Supra 65 05-30-2008 07:44 PM
Engine knock @ 1700-2300 rstutler MKIII Supra 8 03-07-2008 07:36 PM
Knock sensor..........ebay. rnoswal MKIII Supra 0 11-06-2005 07:24 PM


All times are GMT. The time now is 05:08 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86