Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 01-13-2010, 08:08 AM   #1
1_BAD_MK3
Stock
 
1_BAD_MK3's Avatar
 
Join Date: Jan 2010
Location: RIALTO
Posts: 18
Blog Entries: 1
1_BAD_MK3 is on a distinguished road
Question boost lagg

i fixed my car all i needed was a new battery but now it lags boost when u step on the gas it goes but then it bogs and it starts backfiring why
1_BAD_MK3 is offline   Reply With Quote
Old 01-14-2010, 05:33 AM   #2
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Check for diagnostic codes... If you're back firing you're running crazy rich or the timing is off... may be indicative of a knock sensor issue.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 01-14-2010, 09:05 AM   #3
1_BAD_MK3
Stock
 
1_BAD_MK3's Avatar
 
Join Date: Jan 2010
Location: RIALTO
Posts: 18
Blog Entries: 1
1_BAD_MK3 is on a distinguished road
Default

how do i check all that and were is the knock sensor located
1_BAD_MK3 is offline   Reply With Quote
Old 01-14-2010, 05:22 PM   #4
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

http://www.cygnusx1.net/Supra/TechTi...ror_codes.aspx

I just saw your other thread about this matter... After replacing the turbo did you check the spark plugs for fouling and replace them if needed? Also, if the former turbo was dumping too much oil a lot may have accumulated in the IC and piping which will need to be thoroughly flushed out or it may foul new plugs.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 01-15-2010, 01:31 AM   #5
1_BAD_MK3
Stock
 
1_BAD_MK3's Avatar
 
Join Date: Jan 2010
Location: RIALTO
Posts: 18
Blog Entries: 1
1_BAD_MK3 is on a distinguished road
Default

yeah i got new spark plugs checked everything and i found out what was making it lagg it was the main relay
1_BAD_MK3 is offline   Reply With Quote
Old 01-16-2010, 07:31 AM   #6
two-step-n
3" Exhaust
 
Join Date: Oct 2009
Location: mesa az
Posts: 51
two-step-n is on a distinguished road
Default

yeah sounds like the knock sensor i had the same thing happen to me i had to rewire the knock sensor to the ecu bad stock old wire
two-step-n is offline   Reply With Quote
Old 01-16-2010, 07:44 PM   #7
1_BAD_MK3
Stock
 
1_BAD_MK3's Avatar
 
Join Date: Jan 2010
Location: RIALTO
Posts: 18
Blog Entries: 1
1_BAD_MK3 is on a distinguished road
Default

where is the knock sensor located
1_BAD_MK3 is offline   Reply With Quote
Old 01-17-2010, 03:51 AM   #8
Green7mgte
Supra Forum Moderator
 
Join Date: Nov 2009
Location: Green-Ohio
Posts: 1,297
Green7mgte is on a distinguished road
Default

Quote:
Originally Posted by 1_BAD_MK3 View Post
where is the knock sensor located
simple search
knock sensor mk3 supra
http://www.toyota-supra.info/forums/...locations.html
in our very own forum!
__________________

92 Ma71 7mGTE Auto. SafcII
Supra FAQ
Supra MKIII FAQ
Classified Section guidelines :

Green7mgte is offline   Reply With Quote
Old 01-18-2010, 04:24 AM   #9
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

The N/A knock sensor is actually closer to the middle than indicated in that diagram; It's not in the same location as the GTE's rear sensor.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
low boost psi, wtf supradad86_5 MKIII Supra 4 02-09-2014 03:05 AM
Wont accelerate under boost, misfires, backfires, and wont idle Andrew - turbo a MKIII Supra 1 07-24-2009 02:39 PM
wont hold boost Supraman MKIII Supra 12 04-19-2007 05:52 AM
issue w/ boost spikes? i think? NOTORIOUS VR Non-Generation Specific Questions 17 01-17-2007 08:35 PM
No boost in neutral but boost in gear! edgardo MKIII Supra 5 10-09-2004 05:01 AM


All times are GMT. The time now is 07:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86