Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 08-26-2009, 11:48 PM   #1
venomstreetmachine
Banned
 
Join Date: Jun 2009
Location: Abilene Tx
Posts: 10
venomstreetmachine is on a distinguished road
Question Mk3 not boosting ! Help....

Hi guys, I got this sweet Mk3 with all kinds of mods.
i just built this engine with stage 2 internals.
Got a super T4 turbo with 3' V band and an external Tial wastegate.
I also have a Turbo XS T4 manifold.
I have everything hooked up but I am not getting any boost.
The turbo has no shaft play, spins freely by hand ( its brand new)
I start the car and when I rev up I should hear the turbo or see some boost but I dont. I checked all intercooler pipes and vacuum lines,,, checked OK
I reved it up to 5K RPM and let off the gas, my HKS BOV should have gone woosh ! My boost gauge shows -10 and when i gas it, it goes to 0.

Does anyone have any ideas? Perhaps anyone have Vacuum diagrams on the 7MGTE?

Also, what symptoms would occur if the knock sensor is not hooked up and the O2 sensor not plugged in?
venomstreetmachine is offline   Reply With Quote
Old 09-24-2009, 07:53 AM   #2
Sp00nzZ
Stock
 
Join Date: Sep 2009
Location: NC
Posts: 1
Sp00nzZ is on a distinguished road
Default

Yeah, i've encountered the same problem. No boost while sitting still, but boosts fine when im driving.

Dunno, sounds like it may be either a common problem or on purpose from the manufacturer.

^^ dunno, i'd like to know though.
Sp00nzZ is offline   Reply With Quote
Old 09-25-2009, 12:32 AM   #3
DarkSupra2.5
3" Exhaust
 
DarkSupra2.5's Avatar
 
Join Date: May 2008
Location: Sacramento
Posts: 60
DarkSupra2.5 is on a distinguished road
Default

Uh guys, you should only get boost under load, as in, only when driving. If you're getting boost while just sitting there, that's kind of a problem.
__________________
1jz-gte swap (Currently spun #3 rod bearings), Apexi high flow filter, Greddy thrust 3" downpipe, N1 3" catback with cat delete tube, 1 peice driveshaft, Bar and Plate intercooler, and 440 JDM 2jz injectors.

Possible 2jz lower block swap in the works if I can't rebuild the 1j. So troublesome.
DarkSupra2.5 is offline   Reply With Quote
Old 09-25-2009, 02:06 PM   #4
kwnate
SP58GT
 
Join Date: Jul 2005
Location: USA
Posts: 633
kwnate is on a distinguished road
Default

^^ Exactly, drive the car. If you still see no boost then you have a problem. And what exactly are stage 2 internals? Are we playing gt2?
__________________
Nate


kwnate is offline   Reply With Quote
Old 09-28-2009, 09:34 PM   #5
ddmcse
500whp yet?
 
ddmcse's Avatar
 
Join Date: Jun 2005
Location: CT U.S.A.
Posts: 966
ddmcse is on a distinguished road
Cool

gt2 lol . there should be a sticker with the hose diagram stuck under the hood
__________________
300+ RW HP Dyno run,
jdm,mod turbo,3"exh,electfan,greddyboost
Blown HeadGasket info
My Supra KiXGaS
ddmcse is offline   Reply With Quote
Old 11-12-2009, 01:32 AM   #6
SupraJosh
Stock
 
Join Date: Nov 2009
Location: rockport
Posts: 3
SupraJosh is on a distinguished road
Default mk3 not boosting

my mk3 was boosting just fine one day and all of a suddon it just stopped boosting, i have not figured out what it is yet... i have checked the intercooler piping and vacume lines....not boosting at all.
SupraJosh is offline   Reply With Quote
Old 11-12-2009, 06:55 AM   #7
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Check the wastegate... the gate or the actuator could be stuck.

EDIT: didn't see it's an external WG, still should be checked.
cre is offline   Reply With Quote
Reply

Tags
boost, exhaust, mk3, turbo, vacum

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Boosting my 88 7mge lemonhead4696 Non-Generation Specific Questions 5 07-02-2008 03:24 AM
Boosting a 7MGE or swapping it out. Knightryder MKIII Supra 12 08-16-2007 05:45 PM
Safe boosting for na-t supraman121 MKIII Supra 0 01-06-2007 08:13 PM
Boosting Up My Stock Turbo TRD 7M~GTE MKIII Supra 2 02-23-2006 08:30 PM
boosting turbo steve119md MKIII Supra 2 09-15-2005 12:09 PM


All times are GMT. The time now is 12:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86