Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 10-10-2008, 02:17 AM   #1
EthanMKIII
3" Exhaust
 
Join Date: Aug 2008
Location: BC
Posts: 71
EthanMKIII is on a distinguished road
Default Engine Error Code

Well i check the error codes on my supra and i got error 42 Vehicle Speed Sensor Signal whats the problem and wat can i do to fix it>?
EthanMKIII is offline   Reply With Quote
Old 10-11-2008, 10:07 AM   #2
Busted Knuckles
12psi boost
 
Busted Knuckles's Avatar
 
Join Date: Dec 2007
Location: Atlanta
Posts: 300
Busted Knuckles is on a distinguished road
Default

The VSS is in the speedometer. Does your speedo work? Is the speedo cable broken? If everything else is OK, the speedo cluster will need to come out, and the VSS module checked out. I've never done this, but I grabbed a spare cluster from a parts car just in case I have problems with mine.
Busted Knuckles is offline   Reply With Quote
Old 10-11-2008, 05:39 PM   #3
EthanMKIII
3" Exhaust
 
Join Date: Aug 2008
Location: BC
Posts: 71
EthanMKIII is on a distinguished road
Default

Quote:
Originally Posted by Busted Knuckles View Post
The VSS is in the speedometer. Does your speedo work? Is the speedo cable broken? If everything else is OK, the speedo cluster will need to come out, and the VSS module checked out. I've never done this, but I grabbed a spare cluster from a parts car just in case I have problems with mine.
Ya it works perfectly fine. The only problem is that the rad light stays on, i even put a new rad in and it still does it so i think the lights just broken.

I put bigger rims than stock on the car would tha affect it?
EthanMKIII is offline   Reply With Quote
Old 10-12-2008, 11:55 AM   #4
Busted Knuckles
12psi boost
 
Busted Knuckles's Avatar
 
Join Date: Dec 2007
Location: Atlanta
Posts: 300
Busted Knuckles is on a distinguished road
Default

No, I think the VSS is broken. The speedo cluster will have to come out, and the module inspected/replaced.

As far as the rad light, this is a sensor in the coolant reservoir (plastic jug in from of the radiator support) warning of low coolant there. Is yours still connected to the radiator, or is it by-passed?
Busted Knuckles is offline   Reply With Quote
Old 10-13-2008, 08:44 AM   #5
jrok
Intake
 
Join Date: Sep 2008
Location: british columbia canada
Posts: 31
jrok is on a distinguished road
Default the 42 code

its the speed sensor on the tranny
__________________

1984 celica supra with 7mgte swap, custom intercooler, 2.5 exhaust no muffler or cat, shimmed wastegate to 12 lbs boost, with r154 turbo 5-speed tranny 16x8 xxr s13's with 245/50R16 toyo proxes 4's
.http://au.youtube.com/watch?v=rgOxP0PxCwo
.http://au.youtube.com/watch?v=uf989mb3EDw
also own:
2000 4runner 3 inch lift, 33inch tires
.http://au.youtube.com/watch?v=J15k1rCh7-A
1988 4runner stock
.http://au.youtube.com/watch?v=2u7e1_pMqfs
.http://au.youtube.com/watch?v=9lu4j5P6M7M
]
jrok is offline   Reply With Quote
Old 10-14-2008, 01:51 AM   #6
Busted Knuckles
12psi boost
 
Busted Knuckles's Avatar
 
Join Date: Dec 2007
Location: Atlanta
Posts: 300
Busted Knuckles is on a distinguished road
Default

jrok,

EthanMKIII has a five speed Supra. According to the TRSM, the only VSS on this car, like mine, is located in the speedo cluster.
Busted Knuckles is offline   Reply With Quote
Old 10-14-2008, 03:39 AM   #7
jrok
Intake
 
Join Date: Sep 2008
Location: british columbia canada
Posts: 31
jrok is on a distinguished road
Default nope

i get that code also and the wire on the tranny is hanging there the one at the speedo is for cruise trust me
the r154 like i have and with abs there is like 4 wires from the back of the tranny i still have to wire it in
__________________

1984 celica supra with 7mgte swap, custom intercooler, 2.5 exhaust no muffler or cat, shimmed wastegate to 12 lbs boost, with r154 turbo 5-speed tranny 16x8 xxr s13's with 245/50R16 toyo proxes 4's
.http://au.youtube.com/watch?v=rgOxP0PxCwo
.http://au.youtube.com/watch?v=uf989mb3EDw
also own:
2000 4runner 3 inch lift, 33inch tires
.http://au.youtube.com/watch?v=J15k1rCh7-A
1988 4runner stock
.http://au.youtube.com/watch?v=2u7e1_pMqfs
.http://au.youtube.com/watch?v=9lu4j5P6M7M
]

Last edited by jrok; 10-14-2008 at 03:43 AM.
jrok is offline   Reply With Quote
Old 10-14-2008, 03:52 AM   #8
Busted Knuckles
12psi boost
 
Busted Knuckles's Avatar
 
Join Date: Dec 2007
Location: Atlanta
Posts: 300
Busted Knuckles is on a distinguished road
Default

And, I had to rip into my transmission this summer. The sensors in the trannies are for the ABS only. I had to take mine apart, and ride without it. The ABS system light went on, not the CEL, and no the code 43. I had to replace my tranny with one from a non-ABS car, and it had no sensor at all. Because my case was torn up, I had to use it, and lose my ABS. I'm telling you, the VSS is in the speedo, not the transmission.

Look at the TSRM, pages MT-11 for the W58, and MT-54 for the R154. They clearly state the rear sensor (for ABS). Without ABS, no sensor.
Busted Knuckles is offline   Reply With Quote
Old 10-14-2008, 04:02 AM   #9
jrok
Intake
 
Join Date: Sep 2008
Location: british columbia canada
Posts: 31
jrok is on a distinguished road
Default well

on alldata says to put a voltmeter on the wire in the computer a spin the tires then check the sensor at the tranny
im almost 100% you need a vss from the tranny
__________________

1984 celica supra with 7mgte swap, custom intercooler, 2.5 exhaust no muffler or cat, shimmed wastegate to 12 lbs boost, with r154 turbo 5-speed tranny 16x8 xxr s13's with 245/50R16 toyo proxes 4's
.http://au.youtube.com/watch?v=rgOxP0PxCwo
.http://au.youtube.com/watch?v=uf989mb3EDw
also own:
2000 4runner 3 inch lift, 33inch tires
.http://au.youtube.com/watch?v=J15k1rCh7-A
1988 4runner stock
.http://au.youtube.com/watch?v=2u7e1_pMqfs
.http://au.youtube.com/watch?v=9lu4j5P6M7M
]
jrok is offline   Reply With Quote
Old 10-14-2008, 04:05 AM   #10
jrok
Intake
 
Join Date: Sep 2008
Location: british columbia canada
Posts: 31
jrok is on a distinguished road
Default i do see what you mean

but does your speedo work
__________________

1984 celica supra with 7mgte swap, custom intercooler, 2.5 exhaust no muffler or cat, shimmed wastegate to 12 lbs boost, with r154 turbo 5-speed tranny 16x8 xxr s13's with 245/50R16 toyo proxes 4's
.http://au.youtube.com/watch?v=rgOxP0PxCwo
.http://au.youtube.com/watch?v=uf989mb3EDw
also own:
2000 4runner 3 inch lift, 33inch tires
.http://au.youtube.com/watch?v=J15k1rCh7-A
1988 4runner stock
.http://au.youtube.com/watch?v=2u7e1_pMqfs
.http://au.youtube.com/watch?v=9lu4j5P6M7M
]
jrok is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Engine Help! born2drv MKIII Supra 9 02-01-2011 08:14 PM
problem seperating engine from manual tranny Gengus MKIII Supra 7 01-29-2008 12:10 AM
Keeping Engine Cool mrnickleye Supra FAQ 0 06-04-2005 10:02 PM


All times are GMT. The time now is 11:00 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2021, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87 88