Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 06-20-2008, 05:51 PM   #1
RspecMKiii
Stock
 
RspecMKiii's Avatar
 
Join Date: Mar 2008
Location: San Diego
Posts: 10
RspecMKiii is on a distinguished road
Default At Full Engine Warm Up Engine Ildes Down And Sometimes Dies!!!

Hello all!! So i got 99% of the bugs worked out on my 89 turbo..except for the idle problem when engine is fully warmed up. When im driving and i am about to come to a stop I clutch it to downshift and the idle drops below 500 sometimes it recovers other times it just dies out. I am at loss to what it could be any info would be appreciated. Oh one more thing anyone know the Part # for Front and Rear springs for the Eibach Pro-Kit? I think the guy i bought the car from has them reversed cause i am running the same set up on my 88 and its sits/handles like it should this one sits Jack rabbit and is kinda loose around hard cornering.
RspecMKiii is offline   Reply With Quote
Old 06-20-2008, 07:46 PM   #2
supramacist
1000whp postwhore
 
supramacist's Avatar
 
Join Date: Apr 2007
Location: Escape from the Prison Planet
Posts: 1,356
supramacist is on a distinguished road
Default

Sorry my eibachs are still in the box.

As for the idle....., maybe you'll get lucky and just need a couple of fresh fuel filters.

It could be many things. Your description needs to be more detailed.
Could be water in the gas. Start simple.
supramacist is offline   Reply With Quote
Old 06-21-2008, 02:06 AM   #3
RspecMKiii
Stock
 
RspecMKiii's Avatar
 
Join Date: Mar 2008
Location: San Diego
Posts: 10
RspecMKiii is on a distinguished road
Default

When i purchased the supra i replaced the fuel filter,vacuum lines, the head had been rebuilt and i installed it with new gaskets of course. Also i double checked the timing and thats good too. The car runs very strong and i checked for codes but none came up. Any other ideas for me to check are welcomed its on a temporary pass to operate and it ends soon and i need it to pass smog lol. Thanks in advance for the feedback =)
RspecMKiii is offline   Reply With Quote
Old 06-21-2008, 04:17 AM   #4
supramacist
1000whp postwhore
 
supramacist's Avatar
 
Join Date: Apr 2007
Location: Escape from the Prison Planet
Posts: 1,356
supramacist is on a distinguished road
Default

There are 2 fuel filters 1 in tank and the other is on the subframe underneath the back seats.

Is it coughing and sputtering?

Is it over loading, puffing smoke?

Is there a miss under the hood?

If there are no codes it's something simple.

You're just going to have to seek it out and kick yourself for not thinking of it sooner.

Vac leak.

Spray the vac lines down with starting fluid. If it idles up while doing this you have a leak.
supramacist is offline   Reply With Quote
Old 06-21-2008, 07:50 AM   #5
RspecMKiii
Stock
 
RspecMKiii's Avatar
 
Join Date: Mar 2008
Location: San Diego
Posts: 10
RspecMKiii is on a distinguished road
Default

I will try those you mentioned hopefully it IS something as simple that I am overlooking but never the less if it is something simple I am still probably going to kick myself in the A$$ for not realizing it sooner. But I hope for the best...if not expect me to pick your brains for more answers lol =) Again thanks for the feedback...ill get back to you with the results. well probably 5 days from now since its my monday at work >.<

RspecMKiii is offline   Reply With Quote
Old 06-21-2008, 10:55 PM   #6
supramacist
1000whp postwhore
 
supramacist's Avatar
 
Join Date: Apr 2007
Location: Escape from the Prison Planet
Posts: 1,356
supramacist is on a distinguished road
Default

It almost has to be a vac leak man.

No other real explanation.
supramacist is offline   Reply With Quote
Old 06-22-2008, 03:32 PM   #7
mastergrader007
3" Exhaust
 
Join Date: May 2008
Location: Ontario, Canada
Posts: 79
mastergrader007 is on a distinguished road
Default

mine does the same thing, replaced "most of the vaccume lines, but still does it." maybe one of the lines i didnt replace is leaking. if i rev it up and let right off the gas, she sometimes stalls.
mastergrader007 is offline   Reply With Quote
Old 06-22-2008, 08:28 PM   #8
supramacist
1000whp postwhore
 
supramacist's Avatar
 
Join Date: Apr 2007
Location: Escape from the Prison Planet
Posts: 1,356
supramacist is on a distinguished road
Default

I can't think of anything else it could be other than a vac leak.

Alas I am NOT, a mechanic.
supramacist is offline   Reply With Quote
Old 06-22-2008, 11:52 PM   #9
hkssupra
Intake
 
Join Date: Jul 2007
Location: Richmond, VA
Posts: 37
hkssupra is on a distinguished road
Default

one thing came to my mind, do you still have your bov recirculating? I know once i put my hks bov on and blocked off the recirculated bov, i have been having problems with it trying to cut off
hkssupra is offline   Reply With Quote
Old 06-23-2008, 03:29 AM   #10
azerty
3" Exhaust
 
azerty's Avatar
 
Join Date: Sep 2007
Location: Romania
Posts: 96
azerty is on a distinguished road
Default

Quote:
Originally Posted by hkssupra View Post
one thing came to my mind, do you still have your bov recirculating? I know once i put my hks bov on and blocked off the recirculated bov, i have been having problems with it trying to cut off
I also have this problem and also have the HKS BOV, without the recirculating kit.
But... the stalling problem appeared BEFORE I had my HKS BOV installed. So, I guess in your case is just a coincidence.
__________________
1988 yelow manual turbo targa
HKS ssqv bov
Hose Techniques silicon hoses
Forge manual boost controller
boost gauge
K&N FIPK
ACT clutch kit HD-G6
Fidanza lightened flyweel
550cc RC Injectors
255lph Walbro Fuel Pump
LIPP Lexus AFM Replica
3" turbo back echaust with divorced
downpipe and no cats.
Aeromotive FPR
Aem Uego Wideband Gauge+O2 sensor
azerty is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT. The time now is 07:25 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2024, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86 87