Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Search Forums

Showing results 1 to 16 of 16
Search took 0.01 seconds.
Search: Posts Made By: chuck0960
Forum: MKIII Supra 06-29-2011, 05:32 AM
Replies: 8
Views: 4,233
Posted By chuck0960
I thought i took care of the overheating problem...

I thought i took care of the overheating problem but the other day it came back. Im running out of things besides tearing the motor apart again. I looked around for a hydrocarbon tester but nobody in...
Forum: MKIII Supra 06-25-2011, 10:08 PM
Replies: 8
Views: 4,233
Posted By chuck0960
EGR Delete

So i deleted my EGR with the delete kit from Driftmotion. But now i dont know what to do with the vacuum lines that went from it to the hard metal lines under the intake.?. And also what to do with...
Forum: MKIII Supra 06-11-2011, 03:39 AM
Replies: 34
Views: 3,507
Posted By chuck0960
its a new cap as well as thermostat. Someone...

its a new cap as well as thermostat.
Someone before me put that liquid glass stuff in it. U can see it in the radiator fins. So i am thinking that might be clogging the radiator and not letting the...
Forum: MKIII Supra 06-11-2011, 12:14 AM
Replies: 34
Views: 3,507
Posted By chuck0960
The problem was that my CPS wires broke out of...

The problem was that my CPS wires broke out of the clip so I had to wire them up around the clip and I had two of them wrong....dumb me.
Well today I bypassed my heater core...and it still emptied...
Forum: MKIII Supra 06-09-2011, 02:46 AM
Replies: 34
Views: 3,507
Posted By chuck0960
Well it started up yesterday. ran today. but now...

Well it started up yesterday. ran today. but now it decided to do what it did when i bought it. after driving so long and it gets to temp. the antifreeze empties out thru the overflow bottle. SO...
Forum: MKIII Supra 06-08-2011, 04:16 AM
Replies: 34
Views: 3,507
Posted By chuck0960
El Supracabas- i marked everything and put the...

El Supracabas- i marked everything and put the crank at TDC and marked the CPS and then put everything back together the same way.
And yes its getting to be frustrating....it needs to be on the...
Forum: MKIII Supra 06-07-2011, 07:47 PM
Replies: 34
Views: 3,507
Posted By chuck0960
It pops and sometimes backfires xthe plugs are...

It pops and sometimes backfires xthe plugs are dry and smell like fuel. How would I check the open circuit relay to see if it's bad?
Forum: MKIII Supra 06-07-2011, 12:07 AM
Replies: 34
Views: 3,507
Posted By chuck0960
I carefully sprayed ether already. it just spits...

I carefully sprayed ether already. it just spits and sputters like it does when you dont put ether in it.
the reason i bought iridium is because it seemed they were the best ones to buy (guess i...
Forum: MKIII Supra 06-06-2011, 03:08 AM
Replies: 34
Views: 3,507
Posted By chuck0960
so i worked on it a little more tonight. it will...

so i worked on it a little more tonight. it will crank just fine, getting fuel because you can start to smell it (kinda like partially burnt) coming from the exhaust. checked the timing again and...
Forum: MKIII Supra 06-05-2011, 02:20 PM
Replies: 34
Views: 3,507
Posted By chuck0960
I'm pretty sure I have all the grounds. The one...

I'm pretty sure I have all the grounds. The one on the exhaust side towards the back of the head, the coil pack ground, and the huge one under the intake.
And the timing issue, I put the crank tdc...
Forum: MKIII Supra 06-05-2011, 12:19 AM
Replies: 34
Views: 3,507
Posted By chuck0960
Do I need to pull the dash to get to the circuit...

Do I need to pull the dash to get to the circuit opening relay??
Forum: MKIII Supra 06-03-2011, 03:26 AM
Replies: 34
Views: 3,507
Posted By chuck0960
ok. ill have to check that. thanks a lot. i have...

ok. ill have to check that. thanks a lot. i have another question...the clips that go to the fuel injectors are white/grey and orange. does anybody know the order they should go from front to back??...
Forum: MKIII Supra 06-03-2011, 02:07 AM
Replies: 34
Views: 3,507
Posted By chuck0960
Could u point me in any direction of where that...

Could u point me in any direction of where that circuit is located?
And could the KVAFM be why it will crank but not start up???
Patience is a virtue but man this starting to suck
Forum: MKIII Supra 06-03-2011, 12:58 AM
Replies: 34
Views: 3,507
Posted By chuck0960
It ended up being the battery not having enough...

It ended up being the battery not having enough juice. But now it will crank and fire but not run. Can u help me with this?
Forum: MKIII Supra 06-02-2011, 05:02 AM
Replies: 34
Views: 3,507
Posted By chuck0960
NEEd HELp

so i just got done doing a headgasket on my 91 7mgte. i have everything on (i believe). when i turn the key on my fuel pump will no longer turn on to prime the fuel rail...but when i try to crank the...
Forum: MKIII Supra 05-05-2011, 12:45 AM
Replies: 6
Views: 1,350
Posted By chuck0960
performance

so im new to this, first supra (91 mk3 auto), i was wanting to get some recommendations on what to do to be able to turn my boost up to 15psi?? i know i will need fuel system upgrade and turbo...
Showing results 1 to 16 of 16

 
Forum Jump

All times are GMT. The time now is 03:57 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86