View Single Post
Old 05-11-2010, 08:45 AM   #20
pwpanas
Supra Owner
 
pwpanas's Avatar
 
Join Date: Oct 2005
Location: GA, USA
Posts: 2,209
pwpanas is on a distinguished road
Default

Quote:
Originally Posted by mrgdm007 View Post
I cant remember which one the mechanic said but he said since he was taking out the tranny he suggested I might replace the slave cylinder, and he said if I look to get an aftermarket pressure plate or clutch that it would handle the extra pressure, so I would just get it out of the way now
First rule of maintenance - if it ain't broke, don't fix it. *shrug* To me, that's strike one against this 'mechanic'.

P.S. I've seen the mount point for the clutch fork get broken in the past, and could fit with your description of symptoms. This problem can be verified via the inspection port (i.e. without transmission removal).
__________________
Phil '94 Supra Turbo, 6spd, 'APU'+
Displacement is no replacement for boost.
Life begins at 30psi.


NB: Please consider posting any help requests in a new thread instead of asking me for help privately. About 99.9+% of the time, private help requests end up covering great information that could be very valuable to other forum members. If you have a good reason for needing the help request to be private, I'll consider it. If not, then why not give everyone else the opportunity to pitch in too, and/or learn from the information? Remember, there's no such thing as a dumb question. We're all here to help within this family of Supra owners.

Last edited by pwpanas; 05-11-2010 at 08:51 AM.
pwpanas is offline   Reply With Quote