Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > General Discussions > Non-Generation Specific Questions

Reply
 
Thread Tools Display Modes
Old 06-06-2005, 11:04 PM   #1
maksimus54
Stock
 
Join Date: Feb 2005
Posts: 10
maksimus54 is on a distinguished road
Default

Hey, well on my way home from school today i noticed my brakes acting funny. On initial pushing of the brake pedal the brakes would grip like usual, but if i released and then pressed again the brakes didn't grip till the pedal was to the floor. I didn't drive far with it in this condition, so im not sure of all the circumstances it is acting up, just that sometimes it takes a lot of pedal movement to grip. And the brakes are gripping eventually, so they work, just im a bit worried that they might go out.
maksimus54 is offline   Reply With Quote
Old 06-07-2005, 02:29 AM   #2
KingDiamond
12psi boost
 
Join Date: Apr 2005
Location: West Milford, NJ
Posts: 357
KingDiamond is on a distinguished road
Default

well first check your brake fluid, and then i would get a friend or something to keep pressing on the brakes as you look under the car to see if you notice any leaks. No leaks, then you might want to take apart the front brakes and see if anything is hanging up, nothing you can find then go to the back brakes, still nothing wrong then i would probably say your master cylinder is probably shot, ot maybe brake booster.
KingDiamond is offline   Reply With Quote
Old 06-07-2005, 02:42 AM   #3
SuperSupra86
3" Exhaust
 
Join Date: Jun 2005
Location: Deerfield, WI
Posts: 97
SuperSupra86 is on a distinguished road
Default

LMAO....I had the exact same problem today except i had to drive anhour home w/o brakes....but it sound like its probably a brake line leak....that was my problem....10$ fix
__________________
Who needs zoom zoom......I got turbo!!!
SuperSupra86 is offline   Reply With Quote
Old 06-07-2005, 10:11 AM   #4
suprra_girl
7M POWAH! ;)
 
suprra_girl's Avatar
 
Join Date: Jun 2004
Location: New Zealand
Posts: 2,312
suprra_girl has a spectacular aura aboutsuprra_girl has a spectacular aura about
Default

^ agreed.. sounds like a small leak in one of your lines... so you're sucking in air and leaking fluid.. = no braking power
is your e-brake light on?
__________________
Please use the forum to ask your questions as they will get replied to much faster than pming me

Pics of my build.

"Good girls are just bad girls that don't get caught"

Do a diagnostic first!
suprra_girl is offline   Reply With Quote
Old 07-07-2005, 12:47 AM   #5
intense 7MGTE
Stock
 
Join Date: Jul 2005
Posts: 20
intense 7MGTE is on a distinguished road
Default

I just fix the same problem u are having. check for sticking brake calipers
intense 7MGTE is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Two Issues: Front Brakes and Sporadic Vibration Chambers MKIII Supra 0 11-03-2007 04:15 PM
Brakes are acting WEIRD + Oil leak? Rommy MKIII Supra 10 06-05-2006 07:36 PM
Brakes 5M Vs. 7MGTE panda-supra MKII Supra 3 03-22-2006 09:07 AM
Damn Brakes!! dcrusupra MKIII Supra 3 10-04-2005 04:44 PM


All times are GMT. The time now is 03:46 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86