Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 09-26-2006, 01:38 AM   #1
mizuboi
3" Exhaust
 
Join Date: May 2006
Location: orange county so cali
Posts: 228
mizuboi is on a distinguished road
Default coolant loss and alot of it but no puddle?

okay guys here is another question about losing coolant well i've checked and my gf is loosing coolant in her 89 and there is no smell of coolant no waterfall noise and the oil is not milky so what should i do to check if ther is indeed a leak somehwer or i doubt but a bhg? uper and lower hoses look fine
__________________
my modifications
blitz nur spec catback exhaust, JDM 7m-gte, hks head gasket, arp bolts and studs, k&n air filter, Clutch masters FX300, hks SSQ bov, spearco intercooler, NGK iridium plugs
comming:
new fly wheeel
and not running

for sale
car parts for sale
misc. things for sale


stole it from sm
mizuboi is offline   Reply With Quote
Old 09-26-2006, 11:05 AM   #2
suprra_girl
7M POWAH! ;)
 
suprra_girl's Avatar
 
Join Date: Jun 2004
Location: New Zealand
Posts: 2,312
suprra_girl has a spectacular aura aboutsuprra_girl has a spectacular aura about
Default

get in there and look real good
are there signs of water dripping on the a/c radiator or intercooler if it has one

is it coming out of your overflow bottle?

check underneath the intake manifold, near the back above the starter is a water line which feeds the idle speed controller along with the throttle body which then plugs to the front of the intake manifold
check your hoses going to your turbo (if you have one) check the hoses at the back of the motor from the union bolt to the heater pipes
__________________
Please use the forum to ask your questions as they will get replied to much faster than pming me

Pics of my build.

"Good girls are just bad girls that don't get caught"

Do a diagnostic first!
suprra_girl is offline   Reply With Quote
Old 09-26-2006, 10:48 PM   #3
supraman121
12psi boost
 
Join Date: Aug 2006
Location: North Carolina
Posts: 361
supraman121 is on a distinguished road
Default coolant lose

mine 86 loses coolant out the drain plug on the bottom of the radiator it never leave a big puddle just a little spot but im finding that the little drip drip drip makes me lose alot of coolant in a week or so.
__________________
Upgrades- 225/50/R16's Kumho ECSTA AST (KU25) 273 bucks with shipping
Magnaflow exhaust NO KAT
K&N Air Filter

www.myspace.com/coreyjstevens

http://vids.myspace.com/index.cfm?fu...oid=1536317037 <------ this one should work check out the accident one aswell ya i might be a "fat kid" but i sure can move fast!~
supraman121 is offline   Reply With Quote
Old 09-26-2006, 11:31 PM   #4
suprra_girl
7M POWAH! ;)
 
suprra_girl's Avatar
 
Join Date: Jun 2004
Location: New Zealand
Posts: 2,312
suprra_girl has a spectacular aura aboutsuprra_girl has a spectacular aura about
Default

^ buy a new drain plug??
__________________
Please use the forum to ask your questions as they will get replied to much faster than pming me

Pics of my build.

"Good girls are just bad girls that don't get caught"

Do a diagnostic first!
suprra_girl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump


All times are GMT. The time now is 09:17 PM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2018, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86