Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 09-26-2006, 12:54 AM   #1
marc
12psi boost
 
Join Date: Jun 2006
Location: salem mass
Posts: 329
marc is on a distinguished road
Default yet another problem

ok well 1st i installed my new starter and the car has been starting fine. but, today i went to start it did the wum wum wum wum then finally started. as i was driving my lights seemed very dim and my radio could not keep a connection and kept shuttign off, almost liek my battery was dead. then i parked it, tried to start it again, and it wont start wont even crank. im thinking i need a new altenator? any1 agree? or disagree? does any1 know if the voltage regulators come built into the alernators with these supras?
__________________

nothing but the best
-mods- so far
K&N intake fipk
3" megan downpipe
3"turbo elbow
4 washers on the wastegate
highflow cat
short shifter
89+ front bumper, pic soon to come
many more upgrades soon
marc is offline   Reply With Quote
Old 09-26-2006, 01:19 AM   #2
sd88supra
3" Exhaust
 
Join Date: Oct 2005
Location: San Diego, Ca
Posts: 190
sd88supra is on a distinguished road
Default

new alternator for sure. easy to replace.
sd88supra is offline   Reply With Quote
Old 09-26-2006, 03:51 AM   #3
marc
12psi boost
 
Join Date: Jun 2006
Location: salem mass
Posts: 329
marc is on a distinguished road
Default

does the voltage regulator come with the alternator, liek is it built in?
__________________

nothing but the best
-mods- so far
K&N intake fipk
3" megan downpipe
3"turbo elbow
4 washers on the wastegate
highflow cat
short shifter
89+ front bumper, pic soon to come
many more upgrades soon
marc is offline   Reply With Quote
Old 09-26-2006, 10:58 AM   #4
suprra_girl
7M POWAH! ;)
 
suprra_girl's Avatar
 
Join Date: Jun 2004
Location: New Zealand
Posts: 2,312
suprra_girl has a spectacular aura aboutsuprra_girl has a spectacular aura about
Default

yep regulator is built in
check water levels in battery
check with multimeter while car is running to see if your alternator is charging
__________________
Please use the forum to ask your questions as they will get replied to much faster than pming me

Pics of my build.

"Good girls are just bad girls that don't get caught"

Do a diagnostic first!
suprra_girl is offline   Reply With Quote
Old 09-26-2006, 07:46 PM   #5
supra1985turbo
3" Exhaust
 
Join Date: Sep 2006
Location: Kingwood, TX
Posts: 63
supra1985turbo is on a distinguished road
Default

You know personaly I would take the battery to autozone or oriellys to have the battery checked, if you check the battery and alternator while the car is running you can come across with a messed up situation, your alt could be good but reading bad because your bat is so far gone that it is pulling so much from the alt. that the internal reg will not keep up. Trust me found out the hard way. But got my money back. It could also be your bat terms.
supra1985turbo is offline   Reply With Quote
Old 09-27-2006, 12:29 AM   #6
marc
12psi boost
 
Join Date: Jun 2006
Location: salem mass
Posts: 329
marc is on a distinguished road
Default

yep, was a bad battery. replaced it today and its fine now
__________________

nothing but the best
-mods- so far
K&N intake fipk
3" megan downpipe
3"turbo elbow
4 washers on the wastegate
highflow cat
short shifter
89+ front bumper, pic soon to come
many more upgrades soon
marc is offline   Reply With Quote
Old 09-27-2006, 12:52 AM   #7
suprra_girl
7M POWAH! ;)
 
suprra_girl's Avatar
 
Join Date: Jun 2004
Location: New Zealand
Posts: 2,312
suprra_girl has a spectacular aura aboutsuprra_girl has a spectacular aura about
Default

woohoo at least it wasn't too painful
__________________
Please use the forum to ask your questions as they will get replied to much faster than pming me

Pics of my build.

"Good girls are just bad girls that don't get caught"

Do a diagnostic first!
suprra_girl is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ABS Problem? rasclaat_98 MKIII Supra 6 12-13-2010 09:53 PM
speed sensor problem nadircicek Non-Generation Specific Questions 8 10-09-2009 06:58 PM
found the problem brs86supra MKIII Supra 0 05-02-2006 04:42 PM
Boost Problem, I Guess nonstop213 MKIII Supra 0 02-23-2006 07:32 PM
tsp problem for na t supra jdlee123 MKIV Supra 0 09-02-2005 07:01 PM


All times are GMT. The time now is 01:26 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86