Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 08-19-2006, 07:05 AM   #1
h8z2luze
12psi boost
 
h8z2luze's Avatar
 
Join Date: May 2006
Location: Nor*Cal
Posts: 338
h8z2luze is on a distinguished road
Default Got Codes?

I got 3 codes in my 89 n/t supra, 24 - Intake Air Tempature Sensor Signal 41 - Throttle Position Sensor Signal and 52 - Knock Sensor Signal. What do you think of the codes? TIA.
__________________
1989 Supra 7MGE MK3 5-speed project...
http://www.cardomain.com/ride/2385505
h8z2luze is offline   Reply With Quote
Old 08-19-2006, 01:40 PM   #2
f00g00
12psi boost
 
Join Date: Aug 2005
Location: Kuwait
Posts: 292
f00g00 is on a distinguished road
Default

You can read them all from the puter to the component connector to verity wires are fine. The tps and inlet temp have different readings in different conditions. I use my haynes manual to check mine. Knock sensor has a shielded wire that if shorted could cause a problem, just check all connections first though, last time I had some codes the TPS plug was hanging on half way.
on the pics the THA-E2 is you inlet air temp reading.
Attached Thumbnails
Click image for larger version

Name:	TPS.JPG
Views:	261
Size:	80.9 KB
ID:	461   Click image for larger version

Name:	AFM.JPG
Views:	237
Size:	31.8 KB
ID:	462   Click image for larger version

Name:	AFMa.JPG
Views:	250
Size:	49.5 KB
ID:	463  
f00g00 is offline   Reply With Quote
Old 08-19-2006, 06:53 PM   #3
h8z2luze
12psi boost
 
h8z2luze's Avatar
 
Join Date: May 2006
Location: Nor*Cal
Posts: 338
h8z2luze is on a distinguished road
Default

Cool thanks, I will check that out. I know the connections are good thats the first thing I checked.
__________________
1989 Supra 7MGE MK3 5-speed project...
http://www.cardomain.com/ride/2385505
h8z2luze is offline   Reply With Quote
Old 08-19-2006, 08:46 PM   #4
mrnickleye
Old Cowboys Never Die !!
 
mrnickleye's Avatar
 
Join Date: Jun 2005
Location: Mojave Desert, Calif.
Posts: 1,705
mrnickleye is on a distinguished road
Default

Are you having running problems???

If not, then I would clear the codes and drive it awhile, then check for codes again.
__________________
Had a Red 1989 N/A. Automatic. Sports Pkg. w/wing.
TEMS, and some nice MODS. Sold to a friend 10/08/08.
mrnickleye is offline   Reply With Quote
Old 08-20-2006, 05:50 AM   #5
h8z2luze
12psi boost
 
h8z2luze's Avatar
 
Join Date: May 2006
Location: Nor*Cal
Posts: 338
h8z2luze is on a distinguished road
Default

Yea, it idles like crap. Up and down up and down and when I come to a stop it usually dies unless I keep it going.
__________________
1989 Supra 7MGE MK3 5-speed project...
http://www.cardomain.com/ride/2385505
h8z2luze is offline   Reply With Quote
Old 08-20-2006, 07:47 AM   #6
mrnickleye
Old Cowboys Never Die !!
 
mrnickleye's Avatar
 
Join Date: Jun 2005
Location: Mojave Desert, Calif.
Posts: 1,705
mrnickleye is on a distinguished road
Default Main Cause Is ????

This poor idle thing seems to happen to alot of supras. There must be some "usual" cause. I certainly have read a lot of complaints like this.
__________________
Had a Red 1989 N/A. Automatic. Sports Pkg. w/wing.
TEMS, and some nice MODS. Sold to a friend 10/08/08.
mrnickleye is offline   Reply With Quote
Old 08-21-2006, 12:54 AM   #7
h8z2luze
12psi boost
 
h8z2luze's Avatar
 
Join Date: May 2006
Location: Nor*Cal
Posts: 338
h8z2luze is on a distinguished road
Default

I cleared the codes then drove it around the block and got one code 52 - Knock sensor signal. I did have a couple loose bolts on the intake but they are all tight now and it didnt make a diffrence.
__________________
1989 Supra 7MGE MK3 5-speed project...
http://www.cardomain.com/ride/2385505
h8z2luze is offline   Reply With Quote
Old 08-21-2006, 01:10 AM   #8
damdog05
12psi boost
 
damdog05's Avatar
 
Join Date: Apr 2006
Location: Georgia
Posts: 250
damdog05 is on a distinguished road
Default

if someone could direct me as to the location of the knock sensor, and the anything related to it, i also have a code 52. and while i could search harder to find it, i havent found it yet. thanks
__________________
My cars:
85 Trans Am- Ehhh- Gone
83 Rx7- Much Better- Gone
86.5 Supra- Love- Not Gone
damdog05 is offline   Reply With Quote
Old 08-21-2006, 02:13 AM   #9
h8z2luze
12psi boost
 
h8z2luze's Avatar
 
Join Date: May 2006
Location: Nor*Cal
Posts: 338
h8z2luze is on a distinguished road
Default

I was also wondering that. I remeber that I unplugged the TPS and the intake temp sensor and plugged them back in while the car was runing wich would explain those codes. But the knock sensor code is still there. I am wondering if air getting in between the air flow sensor and the intake inlet would make it idle like crap cause someone put a PVC pipe where there looks to be a canister of some kind on your guys' cars. lol. I tist it and the engine speeds up so I know its leaking. If I just got a aluminum pipe with silicone fittings that wont leak would that work??? TIA.
__________________
1989 Supra 7MGE MK3 5-speed project...
http://www.cardomain.com/ride/2385505

Last edited by h8z2luze; 08-21-2006 at 04:44 AM.
h8z2luze is offline   Reply With Quote
Old 08-21-2006, 07:34 AM   #10
Isphius
500whp yet?
 
Isphius's Avatar
 
Join Date: Nov 2005
Location: Long branch, NJ
Posts: 1,006
Isphius is on a distinguished road
Default

That canister is some kind of muffler or something. Its pretty pointless. I actually eliminated mine by getting PVC and shaving down the end to fit in the original adapter, And then i used a 3" rubber coupler on the AFM end. And yes, A vaccum leak from the intake hose will cause bad idle, bad gas mileage, And a weird hesitation or shaking when you start off in gear sometimes. Check that out. But since your computer is putting out codes, something is wrong with the tps most likely.
__________________
Yay the supra assistant is gone!!! WEEE!!
Isphius is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Error Codes 42 and 43 Getphazed MKIII Supra 6 09-14-2008 11:32 PM
Codes 25,26,51! justin1642 MKIII Supra 11 08-30-2007 09:08 PM
codes 22 24 31 kidthunder650 MKIII Supra 16 04-13-2007 12:54 AM
fault codes on a newly re-headed supra lethalwithasupra Non-Generation Specific Questions 5 09-28-2005 09:22 AM
diagnostic codes Alberto O. MKIII Supra 5 07-29-2005 01:50 PM


All times are GMT. The time now is 01:20 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2020, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86