Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 02-27-2010, 07:10 PM   #11
cre

Toyota
Racing
Development
 
cre's Avatar
 
Join Date: Apr 2007
Posts: 5,036
cre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond reputecre has a reputation beyond repute
Default

Okay, just making sure... not the kind of technique you really want spreading around as acceptable. Just don't stomp on it until you get it set properly.

I rather enjoyed the pun, actually.
__________________
If something breaks or you need to contact a member of the administration please post HERE. Unless it's a private or administration matter please post it on the forum. It benefits no one else if car related questions aren't posted for future users and takes away from the time I'm able to spend helping on the rest of the forum.

If you're so inclined I'm always more than happy to accept tips via PayPal.
Tip Jar --->
cre is offline   Reply With Quote
Old 03-04-2010, 04:02 AM   #12
Cameroonski
3" Exhaust
 
Join Date: Dec 2009
Location: Austin, Tx
Posts: 68
Cameroonski is on a distinguished road
Default

Ok, so I fixed the timing, and guess what, it was running great! But... it was short lived. I went to start it up today after lunch and the engine cranked and cranked but didn't go. So...

I checked spark, it was good. Checked connections and hoses, all good. Even tried to jump it. The engine just wouldnt run by itself. So i thought fuel pressure...

I shorted out the two terminals for the fuel pump, and the pump relay started buzzing and the wire got really hot. I checked the continuity in the relay and the resistor, and it said good. I did NOT check it in the relay with power hooked up to it. And when i turned the ignition to ON, the relay did not click. So does this mean bad relay? I also tried feelig the fuel line, and it didnt feel like there was pressure... So please, should i buy a new $50 relay or look for something else? Please

Side note: i did replace the fuel filter two days ago, but i looked at it and it seems fine. And yes, i do have fuel in my tank
Cameroonski is offline   Reply With Quote
Old 03-05-2010, 01:58 AM   #13
Cameroonski
3" Exhaust
 
Join Date: Dec 2009
Location: Austin, Tx
Posts: 68
Cameroonski is on a distinguished road
Default

So i checked the power at the fuel pump connection and it was getting power. So if there was power to it but it wasnt working i figured the pump was bad. So i got it out, and ill be double checking tomorow and mabe try to fix it.

There was a lot of rust and gunk on it and the sock, and there was some that i could see in the old filter. So is there an easy way to de-rust-ify my tank?
Cameroonski is offline   Reply With Quote
Old 03-15-2010, 12:52 AM   #14
Cyto
3" Exhaust
 
Cyto's Avatar
 
Join Date: Jul 2009
Location: USA
Posts: 103
Cyto is on a distinguished road
Default

Mine does the same thing, and I also changed the fuel filter.. right after changing it it started doing it... They're saying bad compression in the valves, and for me to get the cams aligned, and the valves re-shimmed, but gah... any other suggestions?
__________________
Proud owner of a 1988 Toyota Supra Turbo, 105k Miles, and great condition.

I might have to sell it to help pay for school so here's the link.

http://www.toyota-supra.info/forums/...html#post72357
Cyto is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
no spark chrism8799 MKII Supra 6 12-08-2008 12:38 AM
Help needed in first pass at improved appearance finaltable Exterior , Interior, and Detailing 1 06-29-2008 07:34 AM
Before buying an 85 P Supra with 123k what to look for e30cabrio MKII Supra 0 02-24-2008 08:09 PM
6 point Roll Cage? carl johansson Road Racing & Autocross 0 12-01-2007 12:28 AM
MEET UP's TEAM_Bastos Drifting 0 03-02-2006 09:09 PM


All times are GMT. The time now is 03:47 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86