Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 04-04-2009, 09:13 PM   #1
pwrkick
Stock
 
Join Date: Sep 2008
Location: fargo,ND
Posts: 3
pwrkick is on a distinguished road
Default Hesitation of 87 Supra Turbo

well i just put a low miles used engine" 89 7mgte" , Ran good for a couple days seems to lack power and started to hesitate when turbo boost and it gradually got worse and worse so the things i have inspected and replaced were is new fuel pump, new fuel filter took the factory air filter box and put cone shape filter and replaced the fuel pressure regulator off my old engine, checked spark plug wires and the 'plugs' they were black fouled and carboned up so i put NGK platinum's with .031 gap. It seemed to run good for a while " couple hours " and then started to hesitate again and it got worse.
Anyone out there that can help me figure out the problem i would really appreciate it !!
Thanks
__________________
Andy
pwrkick is offline   Reply With Quote
Old 04-05-2009, 05:33 AM   #2
Vacationtime247
3" Exhaust
 
Join Date: Feb 2009
Location: Muncie, IN
Posts: 86
Vacationtime247 is on a distinguished road
Default

Uh oh.....I think I smell a BHG!
VT247
Vacationtime247 is offline   Reply With Quote
Old 04-05-2009, 03:18 PM   #3
will fight for food
3" Exhaust
 
will fight for food's Avatar
 
Join Date: Jun 2008
Location: Birmingham Alabama
Posts: 62
will fight for food is on a distinguished road
Default

is there coolant in the oil or coming out the exhaust
__________________
87 supra 7mgte 3" exhaust
used to be a honda guy but now all about the supra




will fight for food is offline   Reply With Quote
Old 04-07-2009, 12:23 AM   #4
pwrkick
Stock
 
Join Date: Sep 2008
Location: fargo,ND
Posts: 3
pwrkick is on a distinguished road
Default

No coolant in the oil or exhaust ! I took the car in to the Toyota dealer and they said that my Air mass flow sensor is bad and i need to replace it for $1150. So I got an AMF sensor from a friend and installed it and nothing has changed i guess toyota dealerships did not know what the problem is but they would have charged me $1100 for nothing! Now any new ideas ! Help ......
__________________
Andy

Last edited by pwrkick; 04-07-2009 at 02:26 PM. Reason: update
pwrkick is offline   Reply With Quote
Old 04-07-2009, 03:25 PM   #5
will fight for food
3" Exhaust
 
will fight for food's Avatar
 
Join Date: Jun 2008
Location: Birmingham Alabama
Posts: 62
will fight for food is on a distinguished road
Default

the dealer is not as good as most think i would take it to a shop and tell them to find out why it does that it may be something simple like a bad coil or plug
__________________
87 supra 7mgte 3" exhaust
used to be a honda guy but now all about the supra




will fight for food is offline   Reply With Quote
Old 04-07-2009, 03:26 PM   #6
87mk111
3" Exhaust
 
87mk111's Avatar
 
Join Date: Mar 2009
Location: akron, ohio
Posts: 226
87mk111 is on a distinguished road
Default

Check your cat converter. If it's bad, your engine will lose power and hesistate (according to my dad who's a mechanic).
87mk111 is offline   Reply With Quote
Old 04-08-2009, 01:46 AM   #7
suprabahamut
3" Exhaust
 
Join Date: May 2007
Location: greensboro
Posts: 242
suprabahamut is on a distinguished road
Default

It could be your IAC valve. Mine is still hesitating I have linked it to the IAC I have one from my old engine I have cleaned so I am going to put it on soon. But for a blown head gasket take it to someone that can do a cylinder Leak down test it will tell a lot.
suprabahamut is offline   Reply With Quote
Old 08-08-2009, 09:14 PM   #8
lordofthegully
Stock
 
Join Date: Aug 2009
Location: Saskatoon SK Canada
Posts: 1
lordofthegully is on a distinguished road
Default Big Problem Toy Supra 1987 Turbo

Help guys.... this supra i traded my talon for.... it barely accelerates there is no problem with the head gasket engine was recently replaced. turbo spools up as accelerating but car will not get above 2000 RPM. it gets there then lags back totally it will then stall if you let off the gas... turbo spools really high it seems like that could be the problem????
lordofthegully is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
HELP PLEASE Nick0887 Non-Generation Specific Questions 4 02-28-2009 07:26 AM
Sequential Turbo Question suprapoweredsoarer MKIV Supra 1 06-06-2006 01:13 AM


All times are GMT. The time now is 07:11 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86