Home / Toyota Supra Forums

Go Back   Toyota Supra Forums! Join the Supra forum! > Performance, Modification, and Maintenance Forums - for generation specific discussions > MKIII Supra

Reply
 
Thread Tools Display Modes
Old 01-06-2008, 10:37 AM   #1
WhiteTurboZ89
Stock
 
Join Date: Jan 2008
Location: san francisco
Posts: 13
WhiteTurboZ89 is on a distinguished road
Default help me, 2 questions

hi, sometimes my 1989 7mgte will die if gas and shift too hard.
but this only happens like 20% of the time not always. still i dont know wat it is.

2nd question - i drive for half hour or so to my friends house. turned off engine and stayed there for only 5 mins. i start the engine and the idle goes around 500 rpm and it fluctuates a little bit and sometimes (50% of the time ) it will competely die out. but if i turn it on and give it little bit gas right away the engine will go back to normal. my 7mgte doesn't do this when its cold it only happen when engine is warm.
WhiteTurboZ89 is offline   Reply With Quote
Old 01-06-2008, 08:51 PM   #2
suprakid91
3" Exhaust
 
suprakid91's Avatar
 
Join Date: Oct 2007
Location: minnesota
Posts: 119
suprakid91 is on a distinguished road
Default

Quote:
Originally Posted by WhiteTurboZ89 View Post
hi, sometimes my 1989 7mgte will die if gas and shift too hard.
but this only happens like 20% of the time not always. still i dont know wat it is.

2nd question - i drive for half hour or so to my friends house. turned off engine and stayed there for only 5 mins. i start the engine and the idle goes around 500 rpm and it fluctuates a little bit and sometimes (50% of the time ) it will competely die out. but if i turn it on and give it little bit gas right away the engine will go back to normal. my 7mgte doesn't do this when its cold it only happen when engine is warm.

2nd question happens to me too. i think its a bad vacume line somewhere. but thats probably wrong. i dont know.
__________________
91' 7m-gte, sold
suprakid91 is offline   Reply With Quote
Old 01-06-2008, 10:06 PM   #3
CyFi6
3" Exhaust
 
Join Date: Oct 2007
Location: SLO
Posts: 234
CyFi6 is on a distinguished road
Default

first one could be some kind of vac leak but it could be a million other things too like a sensor. Check the throttle position sensor.

Second thing seems pretty common, happens to me everytime i have a hot-restart, apparently its the fuel rail heatsoaking and initially spraying out vapors instead of liquid fuel, not a huge problem i dont think as it goes away pretty fast
CyFi6 is offline   Reply With Quote
Reply

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
a few questions about the mkIV supra :D:D bad.boy MKIV Supra 4 09-17-2008 02:27 PM
Buying a Supra, I have some questions. Ungoliant MKIII Supra 7 12-23-2006 05:17 AM
Need your gus help- a few questions ravenmaster MKIII Supra 10 10-21-2006 10:59 PM
new here, few questions SoooopRa! MKIII Supra 6 08-29-2006 12:25 PM
newbie questions erik MKIII Supra 4 01-10-2006 11:37 AM


All times are GMT. The time now is 08:07 AM.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2019, vBulletin Solutions, Inc.

1986



1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 71 72 73 74 75 76 77 78 79 80 81 82 83 84 85 86